"Abandon update" button for each add-ons should be provided after checking Manual update

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: alice0775, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [AddonsRewrite])

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

9 years ago
"Abandon update" button for each add-ons should be provided after checking Manual update.

[STR]
1.Click "Update add-ons" at upper-right of Extension pane

[Actual result]
I cannot abandon the update of the add-on.
It onry provided "Restart" button.

[Expected]
"Abandon update" button for each add-ons should be provided.
The mockups in bug 562622 have a "Undo this update", but that seems to be for after a restart has occurred (for updates that need restarts).

Boriss: thoughts?
Keywords: uiwanted
OS: Windows 7 → All
Hardware: x86 → All
I'm leaning towards not including an undo/abandon update button.

The pro of including such a button is if a user requested a manual update of all add-ons but then remembered that a few of their add-ons they did not want to update, they would have the option of undoing it right away.  For most updates, which require a restart, the user would not have this point seen the update and decided that they wanted to undo it.  So, the decision would be based on the current add-on, not on the changes present in the update.

The con is that we'd be adding another button to primary UI that few users should ever need that could confuse the installation process.  There's already a way to undo an update by the "Undo this Update" the button in "Recent Updates" (see attachment).  Currently, it's an unfortunate but necessary stage in the UI to require users to restart. By having only a restart button and a confirmation that the add-on's update is nearly ready, the process of completing installation by restarting is more clear.  Another notification or button could make the next action necessary in the path less clear, both by cluttering the UI and possibly implying that the the update has already been included.
Attachment #449074 - Attachment is obsolete: true
Comment on attachment 449074 [details]
Mockup: Current design for undoing an update (see last panel)

Jennifer, that's definitely not the mockup you wanted to upload.
Reporter

Comment 4

9 years ago
I think that most expansion is not considered about the version down.
If the updated addon change its own database structure and/or preference meaning,
undoing will fail. 
The Mockup procedure is very dangerous.
Presumably we can just do this the same as bug 562300?
Whiteboard: [AddonsRewrite]
Reporter

Comment 7

9 years ago
(In reply to comment #5)
> Presumably we can just do this the same as bug 562300?

I think thay are not same.
bug 562300 is talking about installing new addons.
On the other hand, this bug is talking about updating existing adons.
Updating an add-on and undoing the update is not safe way as mentiond in comment #4.
(In reply to comment #7)
> (In reply to comment #5)
> > Presumably we can just do this the same as bug 562300?
> 
> I think thay are not same.
> bug 562300 is talking about installing new addons.
> On the other hand, this bug is talking about updating existing adons.
> Updating an add-on and undoing the update is not safe way as mentiond in
> comment #4.

An update is essentially installing a new version, so they are very similar, the only difference is a small amount of context of what you're installing over the top of.
Reporter

Comment 9

9 years ago
(In reply to comment #8)
I think quite not same.

If an extension updated and the extension changes structure of own database,undoing may fail, because older version can not understand the structure of new database.
So, updating should be canceled before completion of update.
(In reply to comment #9)
> (In reply to comment #8)
> I think quite not same.
> 
> If an extension updated and the extension changes structure of own
> database,undoing may fail, because older version can not understand the
> structure of new database.
> So, updating should be canceled before completion of update.

Unless the extension is restartless it won't be updated until you restart the app.

But I'm confused, you seem to be saying that abandoning the update isn't possible in every case so I'm not sure why you filed this bug. Can you elaborate so I can understand better?
Reporter

Comment 11

9 years ago
We can not abandon when I click "Update add-ons".

comment #2 say,we can undo AFTER completion of update extension. 

And I say that this way is wrong. we should be able to abandon the update BEFORE completion of update.So, I say that "Abandon update" button for each add-ons should be provided after checking Manual update.
In Firefox 4 we have an undo button present for canceling an add-on update in the automatic and manual way.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Keywords: uiwanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.