If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash with "html5.enable" on "true" [@ nsRuleNode::GetBorderData(nsStyleContext*) ]

RESOLVED DUPLICATE of bug 561874

Status

()

Core
HTML: Parser
--
critical
RESOLVED DUPLICATE of bug 561874
7 years ago
4 years ago

People

(Reporter: jpj-at-bugzilla, Unassigned)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

Firefox 3.6.3. "html5.enable" on "true"
Firefox 3.7 (default).



Reproducible: Always

Steps to Reproduce:
1. With Firefox 3.6.3, change the option html5.enable to true
2. With Firefox 3.7, keep the default (html5.enable = true)
3. Go to http://opera-fr.com/pierre/test/crash_fx4/
Actual Results:  
Crash.
(Reporter)

Updated

7 years ago
Version: unspecified → 3.6 Branch
confirming with SM trunk , 

bp-c6638e61-78fa-47d2-8420-5cd062100603
0      seamonkey.exe      nsRuleNode::GetBorderData       layout/style/nsRuleNode.cpp:1775
1     seamonkey.exe     nsRuleNode::GetStyleBorder     layout/style/nsStyleStructList.h:134
2     seamonkey.exe     nsStyleContext::DoGetStyleBorder     layout/style/nsStyleStructList.h:134
3     seamonkey.exe     nsFrame::DidSetStyleContext     layout/generic/nsFrame.cpp:585
4     seamonkey.exe     nsFrame::Init     layout/generic/nsFrame.cpp:368
5     seamonkey.exe     nsSplittableFrame::Init     layout/generic/nsSplittableFrame.cpp:55
6     seamonkey.exe     nsContainerFrame::Init     layout/generic/nsContainerFrame.cpp:102
7     seamonkey.exe     nsCSSFrameConstructor::InitAndRestoreFrame     layout/base/nsCSSFrameConstructor.cpp:4543
8     seamonkey.exe     nsCSSFrameConstructor::ConstructInline     layout/base/nsCSSFrameConstructor.cpp:10789
9     seamonkey.exe     nsCSSFrameConstructor::ConstructFrameFromItemInternal     layout/base/nsCSSFrameConstructor.cpp:3730
10     seamonkey.exe     nsCSSFrameConstructor::ConstructFramesFromItem     layout/base/nsCSSFrameConstructor.cpp:5465
11     seamonkey.exe     nsCSSFrameConstructor::ConstructFramesFromItemList     layout/base/nsCSSFrameConstructor.cpp:9541
12     seamonkey.exe     nsCSSFrameConstructor::ConstructInline     layout/base/nsCSSFrameConstructor.cpp:10807
13     seamonkey.exe     nsCSSFrameConstructor::ConstructFrameFromItemInternal     layout/base/nsCSSFrameConstructor.cpp:3730
.......
Status: UNCONFIRMED → NEW
Component: General → Style System (CSS)
Ever confirmed: true
Keywords: crash
Product: Firefox → Core
QA Contact: general → style-system
Summary: Crash with "html5.enable" on "true" → Crash with "html5.enable" on "true" [@ nsRuleNode::GetBorderData(nsStyleContext*) ]
Version: 3.6 Branch → Trunk
Dup of the html5 deep-tree bug.
Component: Style System (CSS) → HTML: Parser
QA Contact: style-system → parser
Whiteboard: DUPEME
bug 569049 or bug 561874 ?
The latter.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 561874
(Assignee)

Updated

6 years ago
Crash Signature: [@ nsRuleNode::GetBorderData(nsStyleContext*) ]

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.