Closed Bug 570066 Opened 12 years ago Closed 12 years ago

Update UI dialogue box in Firefox disappeared before Firefox could be updated.

Categories

(Toolkit :: Application Update, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla2.0b1

People

(Reporter: Ryuji, Assigned: robert.strong.bugs)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; Win64; x64; en-US; rv:1.9.3a5pre) Gecko/20100602 Minefield/3.7a5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; Win64; x64; en-US; rv:1.9.3a5pre) Gecko/20100602 Minefield/3.7a5pre

After checking for updates in Firefox 3.7a5pre, the dialogue box disappear soon after saying that it is recommended that you install the latest version of Firefox. 

Reproducible: Always

Steps to Reproduce:
1.Go to Help
2.Clink on check for update
3.Wait for Firefox to check for update
4.Dialogue disappear saying it is recommended that Firefox should be updated. 
Actual Results:  
Dialogue box disappear before Firefox could update itself.

Expected Results:  
Dialogue box allow user to update Firefox and then disappear when Finish button is pressed.
Tested with New profile with no add-on. Same problem.
Component: General → Application Update
Product: Firefox → Toolkit
QA Contact: general → application.update
Version: unspecified → Trunk
There are 2 buttons one the dialog.  If I click ask later it will allow me to check again.  If I ask for it to update, It will download the file.  I can close the window without clicking restart now or restart later.  Then the help window shows apply download now option. 

I just tried the same 6/2 nightly and WFM.  32bit Win7.
Jason, just to confirm.

1. You check for updates.
2. The Update UI is displayed and it is checking for updates at this time.
3. The Update UI automatically disappears immediately after displaying that there is an update available without you doing anything.

Thanks
@ Robert 

Yeah, that is correct. 

@ Dale 

I cannot even reach the part where the 2 button appear on the dialog box. It disappear before that part. This happened on a 64 bit nightly. 64 bit seems more unstable than any 32 bit nightly I have encountered.
This is the first report of this type of problem.

Could you try launching in safe mode and see what happens when you check for updates?
http://support.mozilla.com/en-US/kb/Safe+Mode
In safe mode, I received the same results. 

old profile(safe mode) ----> same results
New Profile----------------> same results
New Profile(safe mode) ----> same results
Summary: The dialogue box updating Firefox disappear before updating Firefox. → Update UI dialogue box in Firefox disappeared before Firefox could be updated.
Actually, I saw what it wrote before the update UI dialogue box disappeared. 

It said :

A recommended security and stability update is available, but you do not have the system permissions required to install it. Please contact your system administrator, or try again from an account that has permission to install software on this computer. 

You can always get the latest version of Minefield at: 
http://www.mozilla.org/products/firefox/

I am very sure that the account that I install minefield in is a system administrator. I do not understand why Firefox 3.7a5pre will say I do not have required permission. 

I hope what I have found can help you understand what went wrong.
Please attach to this bug the install.log file that is located in the installation directory. Thanks
Attached file Install log
There appear to also be a couple of errors during the install. Specifically,
ERROR Registering: C:\Program Files (x86)\Minefield\AccessibleMarshal.dll
and
Added Quick Launch Shortcut: Minefield.lnk

The last infers that the path to the user's quicklaunch directory was not writable.

Have any of the filesystem permissions been changed as far as you know?
Which account did you use to install?
This might be an artifact of the 64 bit build install. Did you uninstall it?
bah... just noticed this is a 64 bit Firefox that is inside the "Program Files (x86)" directory due to the installer not supporting 64 bit yet.

Could you try uninstalling 64 bit Firefox, installing 32 bit Firefox, and seeing if it still happens? Thanks
Seems to have solved the problem.
Attached patch patch rev1Splinter Review
This takes care of the dialog disappearing. The remainder will be taken care of in bug 572162.

We don't have a way to test the full manual update path for the case where we don't have permissions. We do test the setting of prefs when clicking the never button and the manual update UI.
Assignee: nobody → robert.bugzilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #451329 - Flags: review?(dtownsend)
Attachment #451329 - Flags: review?(dtownsend) → review+
Pushed to mozilla-central
http://hg.mozilla.org/mozilla-central/rev/9bf041cf9856

The remainder will be taken care of in bug 572162.

There is already in-litmus? in bug 407875 which covers this bug as well so minusing in-litmus
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Flags: in-testsuite-
Flags: in-litmus-
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a6
Robert. You said that in comment 11 that 'this is a 64 bit Firefox that is inside the "Program Files(x86)" directory due to the installer not supporting 64 bit yet.'

If I want a 64 bit Firefox installed in my computer(running 64 bit Windows 7), what should I do? 
Sorry I am not very sure about 64 bit software.
No problem. There are several bugs that will need to be fixed before everything will just *work*... bug 568949 is just one example. For the time being you can uninstall Firefox and run the 64 bit installer. Select Custom and change the install directory to C:\Program Files\Mozilla Firefox\ . You won't get complete integration with Windows until several other bugs are fixed though.
You need to log in before you can comment on or make changes to this bug.