OWA does not logoff, unless you end firefox process

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: toni, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; sl; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; sl; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

In MS Office Outlook Web Access, when you logoff, popup shows, that you successfully logged off. But when you try to use OWA again, you are still logged in. Only way to 100% logoff is to close all firefox windows, or in some cases, when process is still running with all firefox windows closed, kill it with task manager.

Reproducible: Always

Steps to Reproduce:
1. Login to OWA
2. Logoff from OWA
3. Try to use OWA again without closing browser
Actual Results:  
Still logged in after logoff.

Expected Results:  
Logged off from mail server.

- Exchange server 2007
- Since this is MS thing, it works well on IE
- Same problem occurs in Opera 10.53(not that i use it, downloaded it just to try this) and maybe other non IE browsers also
>3. Try to use OWA again without closing browser

How ? With entering the URL again/opening a bookmark or with back forward ?

>when you logoff, popup shows, that you successfully logged off.
apparently you are not logged off. Looks like a owa issue if Opera is also affected. I don't know how the authentication is done in owa, via cookies or http basic authentication ?
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> >3. Try to use OWA again without closing browser
> 
> How ? With entering the URL again/opening a bookmark or with back forward ?

no matter, how you do it, this occurs in any case

> >when you logoff, popup shows, that you successfully logged off.
> apparently you are not logged off. Looks like a owa issue if Opera is also
> affected. I don't know how the authentication is done in owa, via cookies or
> http basic authentication ?

i have no idea, but ill ask the guy, who works with exchange server(IE lover)
is it possible that owa is made to work only with IE?
>i have no idea, but ill ask the guy, who works with exchange server(IE lover)
>is it possible that owa is made to work only with IE?

OWA is made by MS with IE as primary target. The loggoff issue is only a small issue and it's ok if everything else works.

What happens if you do Tools/clear private data, select today and unmark everything except the "active logins" ?
(Reporter)

Comment 4

8 years ago
> What happens if you do Tools/clear private data, select today and unmark
> everything except the "active logins" ?

if i do this, it will log me off
>if i do this, it will log me off
basic authentification is used in that case...

That the logoff doesn't work is the result of a missing logout functionality in the http basic auth RFC. There are ways to workaround this.
This external thread is about the same issue :
http://stackoverflow.com/questions/449788/http-authentication-logout-via-php

marking invalid because this is no browser bug. owa should either implement one of the workarounds and/or the RFC should be changed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.