Firefox reports wrong QuickTime Plugin Version

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Sierk Bornemann, Unassigned)

Tracking

3.6 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; de; rv:1.9.2.4) Gecko/20100527 Firefox/3.6.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; de; rv:1.9.2.4) Gecko/20100527 Firefox/3.6.4

Situation:
Mac OS X 10.6.3 with QuickTime Player X Version 10.0 (113) and QuickTime Framework 7.6.6. No legacy QuickTime Player 7.6.6 installed, only QuickTime Player X with its QT 7.6.6 Framework.



Reproducible: Always

Actual Results:  
Firefox reports wrong QuickTime Plugin Version, although all other browsers (Apple Safari, Google Chromium/Chrome, Opera and even Camino) do report it correct.

Expected Results:  
Firefox (release build as well as nightly trunk build) should report the correct QuickTime Plugin version as all other browsers including latest Camino nightly trunk build are also able to.

Firefox 3.6.4 (RC build 6) reports via "about:plugins":
QuickTime Plug-in 7.6.3
Datei: QuickTime Plugin.plugin
Version: 7.6.3

Camino Version 2.1a1pre (1.9.2.5pre 20100601000904) reports via "about:plugins":
QuickTime Plug-in 7.6.6
File: QuickTime Plugin.plugin
Version: 7.6.6

Opera/9.80 (Macintosh; Intel Mac OS X; U; de) Presto/2.5.27 Version/10.60 reports via "opera:plugins":
QuickTime-Plug-In 7.6.6
/Library/Internet Plug-Ins/QuickTime Plugin.plugin

Safari Version 4.0.5 (6531.22.7) reports via "file:///Applications/Safari.app/Contents/Resources/German.lproj/Plug-ins.html":
QuickTime Plug-in 7.6.6

Google Chrome/Chromium:
Google Chrome 6.0.408.1 (Build 47574) dev reports via "about:plugins":
QuickTime Plug-in 7.6.6 - Version: 7.6.6
Library/Internet Plug-Ins/QuickTime Plugin.plugin

Additionally:
/Library/Internet Plug-Ins/QuickTime Plugin.plugin/Contents/version.plist,
/System/Library/QuickTime/QuickTimeComponents.component/Contents/version.plist,
/System/Library/Frameworks/QuickTime.framework/Versions/A/Resources/version.plist all tell:

CFBundleShortVersionString: 7.6.6
CFBundleVersion: 1729

Question: From where does Firefox fetch the outdated (and obviously not installed!) version number of QuickTime/the QuickTime Plugin, although a newer version is installed and all other browsers (inclusive Camino!) are able fetch to report the correct and actual version number of the QuickTime Plugin and its Framework?
Please check and correct this, if it is faulty.

Comment 1

8 years ago
You probably have an old plugin installed inside your Firefox profile, which overrides the one in /Library/Internet Plug-Ins/ . The other browsers are not looking in the location, so that's why they don't report it.

There's a hidden preference (*) that will show you to use the full pathname of the plugin instead of only the filename. Go to about:config, then search for the preference plugin.expose_full_path . It's false by default, but you can change it to true by double clicking. Then refresh your about:plugins page.

(*) See bug 88183 why it's hidden, see bug 458559 for a solution.

Updated

8 years ago
Version: unspecified → 3.6 Branch
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> You probably have an old plugin installed inside your Firefox profile, which
> overrides the one in /Library/Internet Plug-Ins/ . The other browsers are not
> looking in the location, so that's why they don't report it.
> 
> There's a hidden preference (*) that will show you to use the full pathname of
> the plugin instead of only the filename. Go to about:config, then search for
> the preference plugin.expose_full_path . It's false by default, but you can
> change it to true by double clicking. Then refresh your about:plugins page.
> 
> (*) See bug 88183 why it's hidden, see bug 458559 for a solution.

Thanks for the hint, I have followed your advice and have set plugin.expose_full_path to true.
Result of the about:plugins page:

File: /Library/Internet Plug-Ins/QuickTime Plugin.plugin
Version: 7.6.3

So, your assumption that I have an old plugin installed inside my Firefox profile, which overrides the one in /Library/Internet Plug-Ins/ seems to be false.

And now?
(Reporter)

Comment 3

8 years ago
Issue is solved and fixed.

The cause has been the file pluginreg.dat, in which Quicktime has been falsely registered as version 7.6.3 instead correctly of 7.6.6.
I've started Firefox with creating a fresh new profile and then doing a
 
$ find . -print0 | xargs -0 grep '7.6.3'

in the old profile and additionally in the new created profile to find the cause.
For a solution, I've backed up the pluginreg.dat file in the old profile and now am using the new created one instead.
BTW, while looking into pluginreg.dat and comparing the two files, I've noticed, that the version number of the installed Java-Plugin also falsly has been one version number behind the actual installed Java-Plugin.

I will mark this bug as "RESOLVED FIXED".

P.S.: Any explanations or hints, how that false registry of these two plugins could have happened?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
not fixed, there was no patch. WFM
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.