Merge or at least copy the content of application.ini and platform.ini into Info.plist

RESOLVED WONTFIX

Status

()

Toolkit
Startup and Profile System
RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: Sierk Bornemann, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; de; rv:1.9.2.4) Gecko/20100527 Firefox/3.6.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; de; rv:1.9.2.4) Gecko/20100527 Firefox/3.6.4

Avoid redundant meta information and files and merge (or at least copy) the content of application.ini and platform.ini (vendor, name, version number, build id, SourceStamp, Gecko version) into the XML structure of Firefox.app/Contents/Info.plist (which already does exist and has to exist anyway) to make these two extra .ini files obsolete.

Reproducible: Always




Look at the Info.plist and version.plist files of the other web browsers on the Mac platform (Camino, Safari, Chromium/Chrome, Opera), how they do it and what Plist entries they have got to cover these meta informations and embed them into their Info.plist (and maybe version.plist) files.
I suspect this is probably WONTFIX, as it doesn't provide any benefit to us, and would require us to re-implement the existing startup code in a different way for OS X.
Component: Build Config → Startup and Profile System
Product: Firefox → Toolkit
QA Contact: build.config → startup

Comment 2

8 years ago
Indeed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

8 years ago
(In reply to comment #1)
> I suspect this is probably WONTFIX, as it doesn't provide any benefit to us,
> and would require us to re-implement the existing startup code in a different
> way for OS X.

OK, if application.ini and platform.ini are indispensable, why not at least nevertheless merge/copy the information into Info.plist?
Info.plist does exist, has to exist anyway. All relevant meta information (which is needed or might be needed) is stored there.
Each application on MacOS X does so, has to do so. Even Firefox. But on Firefox these meta informations are dispersed over at least 3 different files: Info.plist, application.ini, platform.ini.
Why not contract all these informations in one file: Info.plist? For the time being it just would mean: copying the informations of application.ini and platform.ini into Info.plist (and embed them into meaningful XML tags, whose naming/semantic might be copied from the tags for example Camino, Safari, Chrome use to store such same meta informations), where other meta information about Firefox also is stored.
And leave application.ini and platform.ini where they are for the time being, if they are so important and indispensable at the moment.

Main benefit: all importent (and possibly important) meta information is concentrated in one place (Info.plist and/or version.plist), and the whole application is a little thing more Mac like in doing so, since such Plist files are THE place of choice to store and provide such information/meta information. If one wants/needs to read such information (for which purpose ever), he is able to read it at one place (Info.plist and/or version.plist) and does not have to dive into the application folder to search and collect the needed information from different files.
You need to log in before you can comment on or make changes to this bug.