Intermittent failure in crashtests/481921.html | assertion count 1 is more than expected 0 assertions from ASSERTION: Should have positive frame time

RESOLVED DUPLICATE of bug 573026

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 573026
8 years ago
8 years ago

People

(Reporter: philor, Unassigned)

Tracking

({assertion})

Trunk
x86
Linux
assertion
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1275658711.1275659283.27740.gz
Linux mozilla-central debug test crashtest on 2010/06/04 06:38:31
s: moz2-linux-slave24

REFTEST TEST-PASS | file:///builds/slave/mozilla-central-linux-debug-unittest-crashtest/build/reftest/tests/layout/generic/crashtests/481921.html | (LOAD ONLY)
REFTEST INFO | Loading a blank page
++DOMWINDOW == 20 (0xa6f9404) [serial = 2261] [outer = 0xa5ef0d8]
###!!! ASSERTION: Should have positive frame time: 'videoData->mTime >= mStartTime', file /builds/slave/mozilla-central-linux-debug/build/content/media/nsBuiltinDecoderStateMachine.cpp, line 1104
gfxImageSurface::GetSize() const (/builds/slave/mozilla-central-linux-debug-unittest-crashtest/build/firefox/libxul.so)
gfxImageSurface::GetSize() const (/builds/slave/mozilla-central-linux-debug-unittest-crashtest/build/firefox/libxul.so)
NS_GetComponentManager_P (/builds/slave/mozilla-central-linux-debug-unittest-crashtest/build/firefox/libxul.so)
__gnu_cxx::hash_map<int, mozilla::ipc::AsyncChannel::AsyncListener*, __gnu_cxx::hash<int>, std::equal_to<int>, std::allocator<mozilla::ipc::AsyncChannel::AsyncListener*> >::hash_map() (/builds/slave/mozilla-central-linux-debug-unittest-crashtest/build/firefox/libxul.so)
NS_GetComponentManager_P (/builds/slave/mozilla-central-linux-debug-unittest-crashtest/build/firefox/libxul.so)
PR_Select (/builds/slave/mozilla-central-linux-debug-unittest-crashtest/build/firefox/libnspr4.so)
__free_tcb (/usr/src/debug/glibc-2.5-20061008T1257/nptl/pthread_create.c:215)
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /builds/slave/mozilla-central-linux-debug/build/content/base/src/nsContentUtils.cpp, line 2714
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /builds/slave/mozilla-central-linux-debug/build/content/base/src/nsContentUtils.cpp, line 2714
REFTEST TEST-UNEXPECTED-FAIL | file:///builds/slave/mozilla-central-linux-debug-unittest-crashtest/build/reftest/tests/layout/generic/crashtests/481921.html | assertion count 1 is more than expected 0 assertions
Comment hidden (Treeherder Robot)
(Reporter)

Updated

8 years ago
Summary: Intermittent failure in crashtests/481921.html | assertion count 1 from ASSERTION: Should have positive frame time → Intermittent failure in crashtests/481921.html | assertion count 1 is more than expected 0 assertions from ASSERTION: Should have positive frame time

Updated

8 years ago
Blocks: 573311

Comment 2

8 years ago
Comment 0 and comment 1 are different failures, and the logs are gone, so INCO.

There are several other bugs on comment 0's assertion: bug 571110, bug 573026.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE

Updated

8 years ago
Resolution: INCOMPLETE → DUPLICATE
Duplicate of bug: 573026
No longer blocks: 573311
No longer blocks: 438871
Keywords: assertion
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.