window control menu doesn't work

VERIFIED FIXED in mozilla0.9

Status

()

Core
XUL
P3
minor
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Casey Perkins, Assigned: Dan M)

Tracking

({pp})

Trunk
mozilla0.9
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I noticed sluggish performance on this issue a couple of months ago, but now it
doesn't work at all.
In Windows, in ANY application, you can press Alt-Space to get the window
control menu (Restore, Move, Size, Minimize, Maximize, Close). This is handy in
order to minimize or maximize a window without reaching for the mouse.
It doesn't work with Mozilla. You can click and get the window control menu
(which defeats the purpose), but the normal keyboard command doesn't work.
(Reporter)

Comment 1

18 years ago
sorry, should probably be under keyboard navigation rather than browser general...
Component: Browser-General → Keyboard Navigation

Comment 2

18 years ago
reassigning
Assignee: asa → don
QA Contact: doronr → sairuh

Comment 3

18 years ago
Dan, I think this is a toolkit issue ...
Assignee: don → danm
Component: Keyboard Navigation → XP Toolkit/Widgets

Comment 4

18 years ago
This bug was still unconfirmed. Since it exists, changing state to New.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 5

18 years ago
This happens because we're consuming all keyboard events, including WM_SYSCHAR, 
since we handle menu keyboard equivalents ourselves. We'd get the system menu if 
we let alt-space messages pass through:

--- nsWindow.cpp-3.296	Thu Oct 26 14:58:42 2000
+++ nsWindow.cpp	Thu Oct 26 14:56:46 2000
@@ -2836,6 +2836,9 @@
             unsigned char    ch = (unsigned char)wParam;
             UINT            char_result;
   
+            // pass alt-space through to the default windowproc
+            if (mIsAltDown && ch == ' ')
+              break;
             //
             // check first for backspace or return, handle them specially 
             //

Of course, this would preclude ever capturing alt-space in any keyboard binding 
for our own purposes. Better perhaps to only let the event pass on if we don't 
have a binding for it, though I don't know how to do that offhand. cc:ing menu 
widget and event folk for comment.

Comment 6

18 years ago
possibly related or dupe of 19328?

Comment 7

18 years ago
So this patch looks good, is there any reason not to use it?
Keywords: patch
Whiteboard: [evaluation needed]
Target Milestone: --- → mozilla0.9

Comment 8

18 years ago
Please consider Doron's comment about this being a dup of bug 19328.
If the patch looks good we could apply it to that specific bug 19328.
Fabian. 
(Assignee)

Comment 9

18 years ago
OK, obviously this one is a dupe of 19328. Note that bug claims the problem 
covered by this bug has been fixed (though in a comment made nearly a year ago). 
I believe I'll just check in the above patch, close this bug and let that one 
live on, since now it mostly complains about alt-then-space.

After thinking and talking about the above patch, we've decided it's probably 
useful. It will of course prevent any XUL alt-space key handler from working, but 
people should know better than to have alt-space key commands.

Once this is fixed, the next bug filed will be that with the system control menu 
open, no keyboard navigation can move from there to the window menubar menus. 
That problem will be similar to bug 19328's alt-then-space problem; I think we 
won't want to try to fix either.
Status: NEW → ASSIGNED
Whiteboard: [evaluation needed]

Comment 10

18 years ago
I checked in the patch in bug 19328; it looks like this one would prevent the 
app from handling ctrl+alt+space (although shift+alt+space should open the 
control menu also).  Marking this fixed, because I know we have another bug 
specifically on alt,space.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
vrfy fixed --tested on winnt using 2001.05.02.12 moz bits.
Status: RESOLVED → VERIFIED
Keywords: pp
You need to log in before you can comment on or make changes to this bug.