Closed Bug 570201 Opened 12 years ago Closed 12 years ago

Prompts should allow linebreaks

Categories

(Firefox for Android Graveyard :: General, defect)

Fennec 1.1
x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mfinkle, Assigned: mfinkle)

References

Details

Attachments

(1 file)

Using a "\n" from JS should create a linebreak in a prompt.
This is for m-1.1 only
Version: Trunk → 1.9.2 Branch
Attached patch patchSplinter Review
Simple CSS patch. We should land on mobile-1.1 so it's ready for any possible 1.1.1 release
Assignee: nobody → mark.finkle
Attachment #449316 - Flags: review?(mbrubeck)
Attachment #449316 - Flags: review?(mbrubeck) → review+
Duplicate of this bug: 570941
This was pushed to 

http://hg.mozilla.org/releases/mobile-1.1/rev/61e279deceed

Does this bug mean it's fixed though? It hasn't been pushed to m-b.
(In reply to comment #4)
> This was pushed to 
> 
> http://hg.mozilla.org/releases/mobile-1.1/rev/61e279deceed
> 
> Does this bug mean it's fixed though? It hasn't been pushed to m-b.

Correct. Just verify on Fennec 1.1 for now please.
verified FIXED using "javascript:alert('foo\nbar')" on 1.1 RC b3
pushed to m-b:
http://hg.mozilla.org/mobile-browser/rev/39d29c21907c
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Verified fixed on:
Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110921
Firefox/9.0a1 Fennec/9.0a1
Device: HTC Desire
OS: Android 2.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.