iPhone client shouldn't try to load file: bookmarks

RESOLVED WONTFIX

Status

Cloud Services
Firefox Home
RESOLVED WONTFIX
8 years ago
6 years ago

People

(Reporter: Jesse Ruderman, Assigned: Dan Walkowski)

Tracking

({relnote})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
One of my bookmarks is a file: URL.  The iPhone client shouldn't try to load this from the iPhone's filesystem!  (Currently, it just spins forever when it tries.)
(Assignee)

Comment 1

8 years ago
I will prevent loading file:// urls and display an alert.
Keywords: relnote

Updated

8 years ago
Depends on: 571284

Updated

8 years ago
Duplicate of this bug: 571284
(Reporter)

Comment 3

8 years ago
For tabs (rather than bookmarks) it might be best to just not show the item in the list.

Comment 4

8 years ago
Moving FFHome-related bugs to new component -> Firefox Home
Component: Experimental Clients → Firefox Home
QA Contact: experimental.clients → firefox-home

Comment 5

8 years ago
We really shouldn't be syncing local URLs in Firefox Sync.

mconnor/philikon?
Not sure about not syncing local URLs.

I have a bunch of file:// bookmarks that point to Apple's locally installed Xcode/developer documentation for example. (Same with JavaDoc for the installed JDKs)

Those are pretty handy to have synced to all my Macs.
The Firefox Home project has been retired, and Mozilla will no longer invest in future work on this project [1]. All bugs related to Firefox Home are being mass resolved.

For those interested in continuing work on this app, the source code for Firefox Home is available on Github [2].

[1] http://blog.mozilla.org/services/2012/08/31/retiring-firefox-home/
[2] https://github.com/mozilla-services/ios-sync-client
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.