Provide API to close all keep alive connections per host

RESOLVED DUPLICATE of bug 648941

Status

()

RESOLVED DUPLICATE of bug 648941
9 years ago
8 years ago

People

(Reporter: mayhemer, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
As keep-alive connections keep/are bound to some information of a sensitive character and that information might become invalid during their lifetime, we have to close them when that happens.

For example, when user enters a different NTLM credentials or logs out or invalidates a certificate used for SSL connection, the connection should be dropped and banned from reuse.

This might be a solution to bug 556291, bug 559186 and at least partial, but significant, to bug 471995.
(Reporter)

Comment 1

8 years ago
Let's try to solve this with using the recently added LOAD_FRESH_CONNECTION load flag.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 648941
You need to log in before you can comment on or make changes to this bug.