http://www.telecitygroup.nl/ generates XML parse error

RESOLVED FIXED

Status

Tech Evangelism Graveyard
Dutch
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: mrz, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 449644 [details]
screen shot

I'm getting this in Firefox (Namoroka build 20100531033559).

XML Parsing Error: not well-formed
Location: http://www.telecitygroup.nl/

Line Number 176, Column 13:  for(i=0;i<5;i++){
------------^

Unable to reproduce in Safari or Chrome.
This has nothing to do with the HTML parser.  They serve the site up as "application/xhtml+xml" to us, so it gets parsed as XML, and it's not well-formed XML.  They serve it as text/html to Safari/Chrome.

So this is a website bug, pure and simple...
Assignee: nobody → dutch
Component: HTML: Parser → Dutch
Product: Core → Tech Evangelism
QA Contact: parser → dutch
And as a note, for Firefox 3.6 official release they serve text/html.  So they're doing some sort of (broken) browser-sniffing, no?
Works on 3.6.x nightlies, too - mrz: is this now working on trunk?
(Reporter)

Comment 4

8 years ago
yes!
(Reporter)

Comment 5

7 years ago
No longer an issue.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.