turning on offline imap by default caused >600 Euro phone bill

RESOLVED DUPLICATE of bug 506024

Status

Thunderbird
Mail Window Front End
P1
critical
RESOLVED DUPLICATE of bug 506024
8 years ago
8 years ago

People

(Reporter: Mirko Dölle, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.2.3) Gecko/20100423 Ubuntu/10.04 (lucid) Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100423 Thunderbird/3.0.4

By updating Thunderbird from version 2.x to 3.0.4 the offline imap feature was turned on automatically, causing >600 Euro phone bill for extra traffic.

Reproducible: Always

Steps to Reproduce:
1.Open Thunderbird for the first time
2.Enter informations for existing IMAP account
3.Thunderbird will download every single mail in all abonned folders, causing huge network traffic and therefor high costs.
Actual Results:  
Thunderbird downloaded all mails in background mode without any notice (and so unnoticed by me), causing abt. 70 MBytes traffic, resulting in a >600 Euro phone bill.

Expected Results:  
Should have prompted if imap-offline-feature should be enabled for the accounts or not.

This bug is related to Bug 385502

Downloading every single E-Mail, in companies this may mean several hundred thousands(!), without any notice an any chance to stop this with a single mouse click, is an absoulte No-Go!

Not everybody has a T3 connection and unlimited network traffic on his hand. In my case, every single Megabyte traffic via my mobile phone costs about 10 Euros!

Also, due auto-enabling the offline-imap-feature, using Thunderbird is limited to fast internet connections with unlimited traffic -- and out of scope for any modem or mobile users (netbooks) and Live Linux distributions.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 506024

Comment 2

8 years ago
3.1 won't turn it on by default for existing profiles (i.e., migration from 2.x to 3.x).

Comment 3

8 years ago
I was duping it against bug 506024 rather than bug 569161 since the reporter was referring to costs imposed by not being able to restrict the download over a metered connection.

Comment 4

8 years ago
Yes, I think that the right thing to do, since this issue will occur for new profiles as well.
(Reporter)

Comment 5

8 years ago
Thunderbird should ask for new accounts as well. There is no difference if I set up a netbook and enter the account informations for my huge company imap account, or if I migrate my previous configuration.

I think the most intuitive way would be to ask the user with a little dialog if he likes to enable the offline-imap-feature, giving him the faster search etc. as pro and warning him of the possibly high traffic on the other side. And I would suggest "disable" as default, to avoid simmilar cases.
You need to log in before you can comment on or make changes to this bug.