Closed Bug 570576 Opened 11 years ago Closed 4 years ago

Windows media plugin fails to play media in FF 3.6.4

Categories

(Core :: Plug-ins, defect)

1.9.2 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: kheal, Unassigned)

References

()

Details

If I try to play Windows media in for example http://www.rtvnh.nl/player.php?stream=ItemTV&item=54368 or http://plugindoc.mozdev.org/testpages/wmp11.html nothing is played.

The system is XP SP3 with WMP 10.  (I keep the old version because I need to use mms protocol).  This used to work until recently (3.6.3 and before) though I cannot be 100% sure it is 3.6.4 which "broke" it.

Plugin doc says Error - the plugin has not loaded

about:plugins reports

Microsoft® Windows Media Player Firefox Plugin

    File: np-mswmp.dll
    Version: 1.0.0.8
    np-mswmp

MIME Type 	Description 	Suffixes 	Enabled
application/x-ms-wmp 	np-mswmp 	* 	Yes
application/asx 		* 	Yes
video/x-ms-asf-plugin 		* 	Yes
application/x-mplayer2 		* 	Yes
video/x-ms-asf 		asf,asx,* 	Yes
video/x-ms-wm 		wm,* 	Yes
audio/x-ms-wma 		wma,* 	Yes
audio/x-ms-wax 		wax,* 	Yes
video/x-ms-wmv 		wmv,* 	Yes
video/x-ms-wvx 		wvx,* 	Yes
This works for me on 3.6.3, but it also works for me on 3.6.4 with version of the plugin 1.0.0.8
As far as I know the Windows Media plugin isn't OOPP in 3.6.4 so there should be no behavior differences (though I suppose it could be a bad interaction). Do you have other (potentially OOP) plugins loaded in other tabs when you get the issue?
Works for me with WMP 11 +  np-mswmp.dll Version: 1.0.0.8

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.4) Gecko/20100527 Firefox/3.6.4 ID:20100527093236
Other plugins, such as Flash etc seem to be working fine.  Thanks for the feedback that it is working for others; has anyone got the combo WMP10 + FF364 working?
Blocks: OOPP
WMP12 also WFM with the plugin in Windows 7 with 3.6.4 build6 as all versions > WMP6.4 should be supported with the plugin.  

Have you tried to look at the settings for WMP10 or tried to reinstall WMP10?
hmm. Can you also double check to see if your plugin is not in the disabled state with 3.6.4?  Did you run into compatibility checks when installing 3.6.4?

I can trigger the error - plugin not loaded if I disable the plugin from the Addon manager and testing the URL.
Also did you install 3.6.4 on top of 3.6.3 or in the standard location?  Did you test with a clean profile?  Sometimes that helps.  Try running Firefox.exe -P to create a test or new profile to see if you still get the issue.
Resolving old bugs which are likely not relevant any more, since NPAPI plugins are deprecated.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.