new crash [@ js_MarkGCThing] in branch

VERIFIED DUPLICATE of bug 57070

Status

()

Core
Networking
P3
critical
VERIFIED DUPLICATE of bug 57070
18 years ago
18 years ago

People

(Reporter: jay, Assigned: brendan)

Tracking

({crash, topcrash})

Trunk
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

18 years ago
A similar crash to the one resolved fixed in bug 53123 has returned, so logging 
a new bug on it here.  Below are the latest talkback entries and a stack trace:

js_MarkGCThing() c7913f64
        jsgc.c line 742
        Build: 2000100910 CrashDate: 2000-10-09 UptimeMinutes: 33  Total: 113 
        OS: MacOS version 9.0.4
        URL: 
        Comment: going to bugzilla page
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=18803230
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=18803230

    js_MarkGCThing 0bafcb16
        http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/js/src/jsgc.c line 
721
        Build: 2000101109 CrashDate: 2000-10-11 UptimeMinutes: 4  Total: 209 
        OS: Windows NT  4.0 build 1381
        URL: 
        Comment: Opened prefs from mail window
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=18929018
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=18929018

    js_MarkGCThing 7eb3a396
        http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/js/src/jsgc.c line 
721
        Build: 2000101109 CrashDate: 2000-10-12 UptimeMinutes: 20  Total: 20 
        OS: Windows NT  4.0 build 1381
        URL: 
        Comment: Trying to read a mail message in my Sent folder.  I had just 
sent a message and got a dialog saying it couldn't write to my Sent folder. So I 
opened my Sent folder and clicked on a message when BOOM.
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=18977638
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=18977638

    js_MarkGCThing a9e586ce
        http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/js/src/jsgc.c line 
750
        Build: 2000101609 CrashDate: 2000-10-16 UptimeMinutes: 1  Total: 1 
        OS: Windows 98  4.10 build 67766446
        URL: 
        Comment: crash related to bug 54896
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=19188106
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=19188106

    js_MarkGCThing() f6e56175
        jsgc.c line 721
        Build: 2000101608 CrashDate: 2000-10-16 UptimeMinutes: 2  Total: 2 
        OS: MacOS version 9.0
        URL: 
        Comment: crash related to bug 54896
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=19188618
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=19188618

    js_MarkGCThing() d8ee2b8a
         line 
        Build: 2000101609 CrashDate: 2000-10-16 UptimeMinutes: 15  Total: 15 
        OS: Linux 2.2.12-20smp
        URL: 
        Comment: crash related to bug 54896
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=19188997
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=19188997

    js_MarkGCThing() 647a2857
         line 
        Build: 2000101609 CrashDate: 2000-10-16 UptimeMinutes: 122  Total: 122 
        OS: Linux 2.2.16-22enterprise
        URL: 
        Comment: Went to theme selection Pull down menu (View -> Apply Theme) 
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=19193799
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=19193799

    js_MarkGCThing 7bd6c165
        http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/js/src/jsgc.c line 
721
        Build: 2000101609 CrashDate: 2000-10-16 UptimeMinutes: 55  Total: 55 
        OS: Windows 98  4.90 build 73010104
        URL: 
        Comment: 
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=19206388
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=19206388

    js_MarkGCThing() fb777dd6
         line 
        Build: 2000101609 CrashDate: 2000-10-16 UptimeMinutes: 17  Total: 17 
        OS: Linux 2.4.0-test9
        URL: PSM install for Linux
        Comment: Crash happened right after clicking the "Install Linux PSM" 
button
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=19212280
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=19212280

    js_MarkGCThing() 359d5b80
         line 
        Build: 2000101609 CrashDate: 2000-10-16 UptimeMinutes: 40  Total: 58 
        OS: Linux 2.4.0-test9
        URL: Java 2.0 plugin install for Linux
        Comment: Clicked "cancel" button
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=19214235
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=19214235

Incident ID 19206388 
js_MarkGCThing [d:\builds\seamonkey\mozilla\js\src\jsgc.c, line 721] 
js_GC [d:\builds\seamonkey\mozilla\js\src\jsgc.c, line 1129] 
js_ForceGC [d:\builds\seamonkey\mozilla\js\src\jsgc.c, line 872] 
js_DestroyContext [d:\builds\seamonkey\mozilla\js\src\jscntxt.c, line 220] 
JS_DestroyContext [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 833] 
nsJSContext::~nsJSContext 
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 369] 
nsJSContext::`scalar deleting destructor' 
nsJSContext::Release 
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 374] 
nsCOMPtr_base::assign_with_AddRef 
[d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp, line 59] 
nsWebShell::Destroy [d:\builds\seamonkey\mozilla\docshell\base\nsWebShell.cpp, 
line 1396] 
nsHTMLFrameInnerFrame::~nsHTMLFrameInnerFrame 
[d:\builds\seamonkey\mozilla\layout\html\document\src\nsFrameFrame.cpp, line
489] 
nsWebShell::Destroy [d:\builds\seamonkey\mozilla\docshell\base\nsWebShell.cpp, 
line 1396] 
nsHTMLFrameInnerFrame::~nsHTMLFrameInnerFrame 
[d:\builds\seamonkey\mozilla\layout\html\document\src\nsFrameFrame.cpp, line
489] 
nsHTMLFrameInnerFrame::`scalar deleting destructor' 
nsFrame::Destroy [d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrame.cpp, 
line 433] 
nsFrameList::DestroyFrames 
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36] 
nsContainerFrame::Destroy 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98] 
nsFrameList::DestroyFrames 
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36] 
nsContainerFrame::Destroy 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98] 
nsBoxFrame::Destroy 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1003] 
nsFrameList::DestroyFrames 
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36] 
nsContainerFrame::Destroy 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98] 
nsBoxFrame::Destroy 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1003] 
nsFrameList::DestroyFrames 
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36] 
nsContainerFrame::Destroy 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98] 
nsBoxFrame::Destroy 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1003] 
nsFrameList::DestroyFrames 
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36] 
nsContainerFrame::Destroy 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98] 
nsBoxFrame::Destroy 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1003] 
nsFrameList::DestroyFrames 
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36] 
nsContainerFrame::Destroy 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98] 
nsBoxFrame::Destroy 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1003] 
nsFrameList::DestroyFrames 
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36] 
nsContainerFrame::Destroy 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98] 
ViewportFrame::Destroy 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsViewportFrame.cpp, line 144] 
FrameManager::~FrameManager 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 405] 
FrameManager::`scalar deleting destructor' 
FrameManager::Release 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 387] 
PresShell::~PresShell 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 1288] 
PresShell::`scalar deleting destructor' 
PresShell::Release 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 1203] 
nsCOMPtr_base::~nsCOMPtr_base 
[d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp, line 50] 
DocumentViewerImpl::`scalar deleting destructor' 
nsCOMPtr_base::assign_with_AddRef 
[d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp, line 59] 
nsWebShell::Destroy [d:\builds\seamonkey\mozilla\docshell\base\nsWebShell.cpp, 
line 1396] 
nsXULWindow::Destroy 
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsXULWindow.cpp, line 325] 
DocumentViewerImpl::`scalar deleting destructor' 
DocumentViewerImpl::Release 
[d:\builds\seamonkey\mozilla\layout\base\src\nsDocumentViewer.cpp, line 359] 
nsCOMPtr_base::assign_with_AddRef 
[d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp, line 59] 
nsWebShell::Destroy [d:\builds\seamonkey\mozilla\docshell\base\nsWebShell.cpp, 
line 1396] 
nsXULWindow::Destroy 
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsXULWindow.cpp, line 325] 
nsWebShell::Destroy [d:\builds\seamonkey\mozilla\docshell\base\nsWebShell.cpp, 
line 1396] 
nsXULWindow::Destroy 
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsXULWindow.cpp, line 325] 
nsWebShellWindow::Destroy 
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsWebShellWindow.cpp, line 1779] 
nsWebShellWindow::Close 
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsWebShellWindow.cpp, line 368] 
nsWebShellWindow::HandleEvent 
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsWebShellWindow.cpp, line 457] 
nsWindow::DispatchEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 686] 
nsWindow::DispatchWindowEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 703] 
nsWindow::DispatchStandardEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 724] 
nsWindow::ProcessMessage 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2797] 
nsWindow::WindowProc 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 952] 
KERNEL32.DLL + 0x3613 (0xbff63613) 
KERNEL32.DLL + 0x248f7 (0xbff848f7) 

A few of the entries mention that this crash is related to bug 54896, so maybe 
this is a dup?
(Reporter)

Comment 1

18 years ago
adding topcrash keywords and [@ js_MarkGCThing] for tracking
Keywords: crash, topcrash
(Assignee)

Comment 2

18 years ago
This could be a dup of bug 57070.

/be
(Assignee)

Comment 3

18 years ago
dup'ing "forward" against 57070.

/be

*** This bug has been marked as a duplicate of 57070 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
verified dup
Status: RESOLVED → VERIFIED
Crash Signature: [@ js_MarkGCThing]
You need to log in before you can comment on or make changes to this bug.