Don't want SESSION RESTORE thank you. If a website freezes and I have to reboot, FF insists on trying to restore and locks up again. It should ask "I can try to restore - would you like me to?", then I could say "NO - I just want a clean browser session".

RESOLVED INVALID

Status

()

Firefox
Session Restore
--
major
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Roger Lee, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

I don't know why, (I've never seen this in older versions of FF). But recently I've had a few lock-ups with one or several websites. This may be the website server, or maybe a temporary glitch with the ISP. However, if I reboot and try again later (or the next day), Firefox seems to think it has a restore option for me, and automatically assumes that I want it. Well, I don't !! The result is that FF attempts to re-open 2 or 3 browsers with maybe 10 active tabs, and at least one of the tabs locks up and jams the PC. It should be very simple - if FF thinks it has a session rstore capability, it should ask me and accept the fact that I'm going to say "NO - give me just one, fresh, new browser with just one tab. I don't want anything else. Please don't assume that I want anything else. I will tell you the URl of where I want to goto when I'm ready". Instead, it locks the PC and after a battle and rebooting maybe twice or three times it finally says that it is embarassed. 

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1.
2.
3.

Can't reproduce it, but it has happened at least half a dozen times or more and is very annoying.
This is not a support forum. For Firefox support, please go to http://support.mozilla.com .

If this bug is to go on, it should not be a major bug, merely, an enhancement. Right now, I'd consider this an invalid bug.

Comment 2

8 years ago
This feature can be disabled if you like.

You can do this by setting browser.sessionstore.max_tabs_undo and browser.sessionstore.max_windows_undo to 0.

http://kb.mozillazine.org/Browser.sessionstore.max_tabs_undo
http://kb.mozillazine.org/Browser.sessionstore.max_windows_undo

If you just want to disable the crash recovery you can use browser.sessionstore.resume_from_crash

http://kb.mozillazine.org/Browser.sessionstore.resume_from_crash
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(In reply to comment #2)
> This feature can be disabled if you like.
> 
> You can do this by setting browser.sessionstore.max_tabs_undo and
> browser.sessionstore.max_windows_undo to 0.

Nope, that doesn't disable this feature. That's something different entirely.

> If you just want to disable the crash recovery you can use
> browser.sessionstore.resume_from_crash
> 
> http://kb.mozillazine.org/Browser.sessionstore.resume_from_crash

This is the feature he wants disabled. Roger, make that pref false.
You need to log in before you can comment on or make changes to this bug.