File with content-type "application/x-javascript" is being set to Content-Disposition: inline?

VERIFIED DUPLICATE of bug 65794

Status

MailNews Core
Networking: SMTP
P3
normal
VERIFIED DUPLICATE of bug 65794
17 years ago
9 years ago

People

(Reporter: Henrik Gemal, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When sending a mail that has a file called "prefs.js" attached, Mozilla will set 
the Content-Disposition as inline.
Is this correct?

The content-type is "application/x-javascript"

Comment 1

17 years ago
rhp, would this be your area? or someone else's? 
Assignee: mscott → rhp

Comment 2

17 years ago
Sorry, this isn't happening for rtm.

- rhp
Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Reporter)

Comment 3

17 years ago
Is every attachment set with Content-Disposition as inline because I'm seeing 
this with other kind of attachments too?

Comment 4

17 years ago
It wansn't in the past. Oh, question...are you running on the tip or the 
release candidates?
(Reporter)

Comment 5

17 years ago
tip...
using win32-mozilla-installer.exe

Comment 6

17 years ago
Oh...ok...well, keep in mind, the tip is not what we are going to be shipping 
for 6.0 so these bugs are all getting futured for now.

- rhp
(Reporter)

Comment 7

17 years ago
Is there someway to indicate that this is in the tip.
I dont know is this also is the branch because I dont have access to that...:(

Comment 8

17 years ago
You don't have to, but that just explains why I am latering it. Its probably an 
issue, but I won't be getting to these until after 6 ships.

- rhp
(Reporter)

Comment 9

17 years ago
Fine... Thanx!
You properly have loads of other things to fix....:)
Ducarroz, do you own MIME now?
(Assignee)

Comment 11

17 years ago
right, reassign to myself
Assignee: rhp → ducarroz
Status: ASSIGNED → NEW

Comment 12

17 years ago
can we revisit this?
Keywords: mozilla1.0
Target Milestone: Future → ---
Duping this into 65794.

*** This bug has been marked as a duplicate of 65794 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 14

16 years ago
verified duplicate
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.