Status

--
enhancement
RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: contact, Unassigned)

Tracking

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; fr; rv:1.9.0.19) Gecko/2010051911 Camino/2.0.3 (MultiLang) (like Firefox/3.0.19)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; fr; rv:1.9.0.19) Gecko/2010051911 Camino/2.0.3 (MultiLang) (like Firefox/3.0.19)

While waiting for <ruby> to be supported by Gecko, wouldn't it be possible to use CSS to achieve the same thing ?

Reproducible: Always
(Reporter)

Comment 1

8 years ago
Created attachment 449882 [details]
Example userContent.css
(Reporter)

Comment 2

8 years ago
Created attachment 449883 [details]
Testcase
(Reporter)

Comment 3

8 years ago
I forgot to say that this was about HTML5 ruby only, XHTML ruby is more complicated.

Comment 4

8 years ago
Adding default browser styling for an unknown element strikes me as a bad idea; having consistent handling of unknown elements is a good thing, not a bug. As with pretty much all the other elements people want to use before they are actually supported, I think the right answer is for pages that care to use a normalization script and/or style sheet, not for us to hack something up (which could easily *break* such a script). Strongly suggest WONTFIX.
I have no idea what this is, other than something related to Japanese, but just skimming the Gecko bugs on the subject (bug 33339 (!) and bug 256274), it seems like there are a number of very complex issues that have hampered getting this right, so a quick CSS hack doesn't seem to be the right solution here.

Since it's easy to add to userContent and doesn't seem like a general-purpose feature, I think people who would benefit from the CSS hack can install it as a CSS hack.

(In reply to comment #4)
> Strongly suggest WONTFIX.

Seconded.

Comment 6

8 years ago
I agree with Stuart. Publishers who want to use this element should provide styling themselves (a few Jpn sites that use ruby and care for more than IE actually use similar rules as the ones suggested above).

Providing those rules in Camino may conflict with what those publishers do and lead to worse results.

--> WontFix per general agreement
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.