TBPL should display hg id of last green build

RESOLVED WONTFIX

Status

enhancement
RESOLVED WONTFIX
9 years ago
4 years ago

People

(Reporter: justin.lebar+bug, Unassigned)

Tracking

Details

Right now, when I push to try, I usually get some number of test failures.  I then have to spelunk and try to determine if I caused those errors or if they're known problems.  This is annoying enough that I usually just ignore the errors unless they're obviously caused by my patch.  This has caused me to almost miss major errors in some patches.

We could make this process a little better by having Tinerbox display the hg id of the last all-green build it's seen.  Before I pushed to try, I could hg up to that build; then I could be assured that any failures I see are either caused by my changes or by a random red.
Assignee: nobody → build
Component: Tinderbox → Tinderbox Configuration
Product: Webtools → mozilla.org
QA Contact: tinderbox → ccooper
Version: Trunk → other
Assignee: build → nobody
Component: Tinderbox Configuration → Tinderbox
Product: mozilla.org → Webtools
QA Contact: ccooper → tinderbox
Is there any progress on this? AFAIK this shouldn't be too hard to implement and it would be a major improvement for a lot of people.
Furthermore it would also be great to display the hg id of the last green build for different OS.
Honestly, I think this was a bigger issue back when I filed a year ago than it is today.  It's now relatively easy to go on TBPL and look up the id of the last green build.

How would this be a major improvement for you?

I'm going to move this to the TBPL component, since that's where we'd want to implement this.
Component: Tinderbox → Tinderboxpushlog
QA Contact: tinderbox → tinderboxpushlog
Summary: Tinderbox should display hg id of last green build → TBPL should display hg id of last green build
That would require adding an explicit list of ran jobs so we can be sure all of them are present and not failing. This isn't great but would require maintainance when jobs will be removed/added.
I've written a python script that should automatically compile the last green
build revision with some optimizations for my system, but currently I'm only
compiling the last nightly revision, cause I cannot get the revision of the
latest green tb build. It would be great if the latest green hg id would be
shown somewhere in a file or at the top of the tbpl so it's easy to parse out
of the html code. Currently I cannot find a way how to get the last green
revision out of my script. (sry if this can somehow be done very easily, but I
would really like to get this script working, so I can always have the most
bleeding edge firefox build in my RAMDisk ;)

edit: just read Mounirs comment; didn't think this would be so hard to implement & maintain... I can also live with nightly builds if it's so circumstantially ;)
I honestly think it makes a lot of sense to compile the last nightly.  That's what all the developers I know run!
I think this isn't such a big deal now, so I'm closing this.  Please feel free to re-open if you disagree!
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Resolution: FIXED → WONTFIX
Product: Webtools → Tree Management
Version: other → unspecified
Product: Tree Management → Tree Management Graveyard
You need to log in before you can comment on or make changes to this bug.