Charset overriding for envelope is not working if the msg's header has wrong charset label

VERIFIED FIXED

Status

P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: ji, Assigned: mscott)

Tracking

({intl})

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
This problem is separated from Bug 56685.

If a msg's header has wrong charset label, the envelope is not
displayed correctly even after resetting the view default charset to the proper
charset or selecting proper charset from menu for that particular mail.

Steps to reproduce:
1. Unzip the testing folder to you local folder directory. ( I'll attach the
mail folder later.). The 1st mail in the folder is an iso-2022-JP mail w/o mime
header. the 2nd mail is a big5 mail which has its header incorrectly labeled as
iso-8859-1.
2. Highlight the 1st mail, select View | Character Encoding | Japanese
(ISO-2022-JP) or set the view default charset to ISO-2022-JP from Edit |
Preferences | Mail and Newsgroup | Message Display, you'll see the envelope of
the mail is displayed correctly.
3. Highlight the 2nd mail, do the same thing at step 2 except that the charset
this time should be set to Chinese Traditional (Big5). you'll see the contents
of the mail is correctly displayed, but not the envelope.
(Reporter)

Comment 1

18 years ago
Created attachment 17396 [details]
A mail folder containing the two msgs mentioned in the report.

Comment 2

18 years ago
Reassign to mscott.
Scott, do you remember if we implemented override for envelop view?
Assignee: nhotta → mscott

Updated

18 years ago
Keywords: intl

Comment 3

18 years ago
ji, please check the current status of this bug.
It seems to be working for Windows.
(Reporter)

Comment 4

18 years ago
Just checked 121414-mtrunk linux build. Charset overriding for envelope is
working if the hearder has no charset label at all. But it's still not working
if the header has a wrong charset label.

Updated

18 years ago
Keywords: nsbeta1

Comment 5

18 years ago
marking nsbeta1-
Keywords: nsbeta1 → nsbeta1-

Comment 6

18 years ago
Mass change of QA contact to ji for the bugs filed by her.
QA Contact: momoi → ji

Comment 7

18 years ago
I believe this was fixed by my checkin of attachment id 26422 for bug 65277.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

18 years ago
Verified with 04/17 trunk builds.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.