Closed Bug 570905 Opened 10 years ago Closed 10 years ago

intermittent timeout (1200 seconds without output) in test_adaptive.js

Categories

(Toolkit :: Places, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: dbaron, Assigned: mak)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1276058151.1276061058.10795.gz
Rev3 Fedora 12 mozilla-central opt test xpcshell on 2010/06/08 21:35:51

TEST-PASS | /home/cltbld/talos-slave/mozilla-central-fedora-opt-u-xpcshell/build/xpcshell/tests/test_places/unit/test_536081.js | test passed

command timed out: 1200 seconds without output, killing pid 1977
process killed by signal 9
program finished with exit code -1
that means a timeout in test_adaptive.js, could be related to Bug 539247
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1282540307.1282543230.12356.gz
WINNT 5.2 mozilla-central debug test xpcshell on 2010/08/22 22:11:47
s: win32-slave07

TEST-PASS | e:\builds\moz2_slave\mozilla-central-win32-debug-unittest-xpcshell\build\xpcshell\tests\test_places\unit\test_536081.js | test passed
TEST-INFO | e:\builds\moz2_slave\mozilla-central-win32-debug-unittest-xpcshell\build\xpcshell\tests\test_places\unit\test_adaptive.js | running test ...

command timed out: 1200 seconds without output
program finished with exit code 1
Summary: intermittent timeout (1200 seconds without output) after test_536081.js → intermittent timeout (1200 seconds without output) in test_adaptive.js, after test_536081.js
http://tinderbox.mozilla.org/showlog.cgi?log=Electrolysis/1283412228.1283414705.22771.gz
WINNT 5.2 electrolysis debug test xpcshell on 2010/09/02 00:23:48
s: try-w32-slave23
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1283914018.1283916360.11254.gz
WINNT 5.2 mozilla-central debug test xpcshell on 2010/09/07 19:46:58
s: mw32-ix-slave17

TEST-INFO | e:\builds\moz2_slave\mozilla-central-win32-debug-unittest-xpcshell\build\xpcshell\tests\toolkit\components\places\tests\unit\test_adaptive.js | running test ...

command timed out: 1200 seconds without output


Note that there were a couple of earlier instances of this, in bug 539247, before that got morphed into a separate assertion failure.
OS: Linux → All
Hardware: x86 → All
Summary: intermittent timeout (1200 seconds without output) in test_adaptive.js, after test_536081.js → intermittent timeout (1200 seconds without output) in test_adaptive.js
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1283919249.1283921597.849.gz
WINNT 5.2 mozilla-central debug test xpcshell on 2010/09/07 21:14:09
s: mw32-ix-slave09
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1284050537.1284052900.30785.gz
WINNT 5.2 mozilla-central debug test xpcshell [testfailed]

TEST-INFO | e:\builds\moz2_slave\mozilla-central-win32-debug-unittest-xpcshell\build\xpcshell\tests\toolkit\components\places\tests\unit\test_adaptive.js | running test ...

command timed out: 1200 seconds without output
program finished with exit code 1
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1284142092.1284144497.17016.gz
WINNT 5.2 mozilla-central debug test xpcshell on 2010/09/10 11:08:12  

TEST-INFO | e:\builds\moz2_slave\mozilla-central-win32-debug-unittest-xpcshell\build\xpcshell\tests\toolkit\components\places\tests\unit\test_adaptive.js | running test ...

command timed out: 1200 seconds without output
program finished with exit code 1
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1285122185.1285124626.29016.gz
WINNT 5.2 mozilla-central debug test xpcshell on 2010/09/21 19:23:05  

TEST-INFO | e:\builds\moz2_slave\mozilla-central-win32-debug-unittest-xpcshell\build\xpcshell\tests\toolkit\components\places\tests\unit\test_adaptive.js | running test ...

command timed out: 1200 seconds without output
Duplicate of this bug: 599250
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1286405383.1286407924.3880.gz
WINNT 5.2 tracemonkey debug test xpcshell on 2010/10/06 15:49:43
s: w32-ix-slave22
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1286442749.1286445161.12112.gz
WINNT 5.2 mozilla-central debug test xpcshell on 2010/10/07 02:12:29
s: mw32-ix-slave04
buildbot.slave.commands.TimeoutError: command timed out: 1200 seconds without output
I'm under the impression that the increase in this orange is caused by vacuum, the doAdaptiveDecay function is invoking vacuum multiple times, that makes the test slow like hell. The increase could be due to the fix in bug 575357 (landed on 31 Aug), we will now start multiple vacuum before having a date for the last one and thus skipping next ones.
For now we should set the last_vacuum date at the test start, and later fixing bug 595139 should remove the problem. Will try to push a small fix later.
I'm not sure this will fix all the underlying issues we could have (most likely removing temp tables would) but it should bring us back to the old failure ratio (pretty rare). At least I hope.
Attachment #482280 - Flags: review?(dietrich)
Comment on attachment 482280 [details] [diff] [review]
skip vacuum and use batches

r=me, let's give it a shot.
Attachment #482280 - Flags: review?(dietrich) → review+
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1287079145.1287081598.31448.gz
WINNT 5.2 mozilla-central debug test xpcshell on 2010/10/14 10:59:05
s: mw32-ix-slave08
pushed the "disable vacuum" fix.
http://hg.mozilla.org/mozilla-central/rev/397c458b40a4
Can this be marked fixed now?
whatever!
Assignee: nobody → mak77
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.