User/Password is not remembered when using keys to navigate in "password window" (space doesn't fire onCommand for checkboxes)

RESOLVED WORKSFORME

Status

P3
major
RESOLVED WORKSFORME
18 years ago
14 years ago

People

(Reporter: ezh, Assigned: jag-mozilla)

Tracking

({access})

Trunk
x86
Windows 98
access

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Open a passwod protected site.

Enter name, password, TAB to "remember my password" (or how calls it?), press
Space to activate the "remember button", TAB to OK, you entered the site.

When entering the same site second time (new session?) the same _blank_
user/password dialog appears.

With mouse click on the "remember button" all works fine.

Comment 1

18 years ago
what build are you using?
(Reporter)

Comment 2

18 years ago
I just tested it with 2000101904-Mtrunk.

Acctually it never worked with keyboard.

Comment 3

18 years ago
over to keyboard nav.
Assignee: asa → don
Component: Browser-General → Keyboard Navigation
QA Contact: doronr → sairuh
password manager bug? if not, punt back (or, punt to appropriate owner ;).
Assignee: don → morse
Component: Keyboard Navigation → Single Signon
QA Contact: sairuh → tpreston

Comment 5

18 years ago
Punting back.

What reporter is saying is when he gets the password-manager dialog and checks 
off the box to "remember this decision", everything works fine.  But if instead 
of checking it off, he tabs to it and presses space, it doesn't remember the 
password.  I just tried it and was able to reproduce the behavior.

So this would be a generalized xul issue and not at all restricted to the 
password-manager dialog.  Any dialog created with universalDialog that contains 
a checkbox would have the same problem.  Namely the returned argument indicating 
the state of the checkbox will not be correct if the user checked the box with 
the tab and space keys as indicated.
Assignee: morse → don
Component: Single Signon → XP Apps
QA Contact: tpreston → sairuh

Comment 6

18 years ago
This is strange; hyatt, any ideas?

Comment 7

18 years ago
commonDialog.xul:

      <!-- checkbox -->
      <box id="checkboxContainer" collapsed="true" autostretch="never">
        <checkbox id="checkbox" oncommand="onCheckboxClick(this)" 
style="max-width: 40em;"/>
      </box>

commonDialog.js:

function onCheckboxClick(aCheckboxElement)
{
  gCommonDialogParam.SetInt(1, aCheckboxElement.checked);
}

I guess oncommand isn't called when you press space. Should an onkeypress be 
added, or should we make pressing space call oncommand in xulBindings.xml?
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy
Assignee: don → vishy

Comment 9

18 years ago
space needs to fire oncommand, for certain widgets at least.  And that 
shouldn't be called "onCheckboxClick", since it's not.

Comment 10

18 years ago
So it should be per widget, and not per instance, but also not across the board 
for all widgets. And yeah, once that changes, all these "Click" handlers need to 
be renamed since they really are Command handlers, conceptually different.

Comment 11

18 years ago
nav triage bug:

Would be nice to fix, but don't think we'll get to it for beta1, marking
nsbeta1-, reassigning to pchen
Assignee: vishy → pchen
Keywords: nsbeta1-

Comment 12

18 years ago
changing qa contact to myself, this is my area now
QA Contact: sairuh → tpreston

Comment 13

18 years ago
Marking nsbeta1- bugs as future to get off the radar
Target Milestone: --- → Future

Updated

18 years ago
Keywords: access
Summary: User/Password is not remembered when using keys to navigate in "password window" → User/Password is not remembered when using keys to navigate in "password window" (space doesn't fire onCommand for checkboxes)

Comment 14

17 years ago
This bug mustn't be futured, it's got a severity of major.  And pchen has left 
the company, so reassigning to jag since he had some ideas posted above.
Assignee: pchen → jaggernaut
Target Milestone: Future → ---
(Reporter)

Comment 15

17 years ago
I believe it works now...
(Assignee)

Comment 16

17 years ago
Indeed, WFM.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.