When opening after a crash downloading files should be paused (and a notice added)

RESOLVED DUPLICATE of bug 569545

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 569545
9 years ago
9 years ago

People

(Reporter: svenne, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100519 Gentoo Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100519 Gentoo Firefox/3.6.3

Today a lot of sites and vendors requires a web-logon to download files (Xilinx for example).  This is usually handled by some session cookie or the like. 

Mozillas auto-resume for downloading files makes these fail badly (usually the files are overwritten by some html) if the browser was shut down uncleanly (regardless if it was Firefox or the OS that crashed). This might destroy hours worth of downloading which could otherwise have been resumed...

It would be nice, if downloads would not be auto resumed, but paused and a warning "you have paused download" to be shown. 

Reproducible: Always
The symptoms are different, the root problem is the same as bug 569545
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 569545
You need to log in before you can comment on or make changes to this bug.