Fullscreen mode isn't quite fullscreen.

RESOLVED DUPLICATE of bug 490621

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 490621
8 years ago
4 years ago

People

(Reporter: zbuhman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

The idea is to make fullscreen even more immersive.

Reproducible: Always

Steps to Reproduce:
1. Open any website
2. Switch to fullscreen 
Actual Results:  
Notice that the toolbars/tabs disappear, but a ~10px creme bar (representing the "minimized" toolbars) still appears

Expected Results:  
What I'd like to see, I'm sure you guys get this a lot, but, just as an example, I like how Google Chrome has solved this problem:  fullscreen mode in Chome is quite honestly as "full-screen" as fullscreen gets.  When the user moves the mouse up to the top, it elegantly drops-down a semi-transparent little box that says something like "Leave Fullscreen (F11)".  I myself would even remove the little box and have firefox drop out of fullscreen mode ONLY in the event of F11 (and certainly not drop back to windows mode if the user task-switches).

What also might be nice is if firefox did this in a hardware accelerated overlay, most likely giving it a further greater advantage to use, probably making it faster.  However, how would plugins that also use overlays behave in such an environment?

An added bonus: this would solve the flickering problem firefox has when you move your mouse up to the toolbar/address bar area and have it displayed: the page flickers pretty horribly as the page is resized.  In this fullscreen method, the page isn't resized.

Comment 1

8 years ago
There are extensions on addons.mozilla.org that can change this behavior.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 490621
(Reporter)

Comment 2

8 years ago
Hmm, is there? 

I did find https://addons.mozilla.org/en-US/firefox/addon/4650/ and it does fix a few of the annoyances with fullscreen, but it doesn't *remove* the top-most pixels.

Do you mind giving an example of what extension you're referring to specifically?
You need to log in before you can comment on or make changes to this bug.