Assertion: Someone forgot to call EndUpdateViewBatch!: '!mRootVM' in nsIViewManager.h, line 296

RESOLVED DUPLICATE of bug 611798

Status

()

RESOLVED DUPLICATE of bug 611798
9 years ago
8 years ago

People

(Reporter: Ehsan, Assigned: Ehsan)

Tracking

({assertion, testcase})

Trunk
x86
Windows Server 2003
assertion, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

9 years ago
###!!! ASSERTION: Someone forgot to call EndUpdateViewBatch!: '!mRootVM', file e:\builds\moz2_slave\mozilla-central-win32-debug\build\obj-firefox\dist\include\nsIViewManager.h, line 296
xul!mozilla::gl::GLContextProviderOSMesa::operator=+0x000000000012DC2E
xul!DumpJSValue+0x0000000000039EA3
xul!DumpJSValue+0x000000000004F7EB
xul!DumpJSValue+0x000000000004F12F
xul!mozilla::gl::GLContextProviderOSMesa::operator=+0x000000000012E450
xul!DumpJSValue+0x000000000004F8DD
xul!NS_LogCOMPtrRelease_P+0x000000000000F06B
0x0000000010002E4F
xul!gfxWindowsNativeDrawing::operator=+0x00000000001CE2F2
xul!gfxWindowsNativeDrawing::operator=+0x00000000001CA647
xul!gfxAlphaBoxBlur::operator=+0x0000000000056509
xul!NS_InvokeByIndex_P+0x0000000000000027
xul!mozilla::gl::GLContextProviderOSMesa::operator=+0x000000000004D8A8
xul!mozilla::gl::GLContextProviderOSMesa::operator=+0x000000000004BA65
xul!mozilla::gl::GLContextProviderOSMesa::operator=+0x000000000004B7B7
xul!mozilla::gl::GLContextProviderOSMesa::operator=+0x00000000000602C0
mozjs!JS_XDRNewMem+0x000000000008CD7D
mozjs!JS_XDRNewMem+0x000000000009D0B8
mozjs!JS_XDRNewMem+0x000000000008CDF6
mozjs!JS_XDRNewMem+0x000000000008D50C
mozjs!JS_XDRNewMem+0x0000000000024CEF
xul!gfxTextRunWordCache::operator=+0x000000000002E899
xul!gfxTextRunWordCache::operator=+0x0000000000069DA2
xul!gfxTextRunWordCache::operator=+0x000000000006A868
xul!NS_DestroyXPTCallStub_P+0x0000000000000E0E
xul!NS_DestroyXPTCallStub_P+0x0000000000000FF1
xul!NS_GetComponentRegistrar_P+0x0000000000005BBA
xul!mozilla::layers::LayerManagerOGL::operator=+0x00000000001A0793
xul!std::_Init_locks::operator=+0x000000000000FD8D
xul!gfxThebesUtils::GfxRectToIntRect+0x0000000000000BA6
xul!gfxThebesUtils::GfxRectToIntRect+0x0000000000000AE2
xul!gfxThebesUtils::GfxRectToIntRect+0x00000000000009C3
xul!gfxD2DSurface::operator=+0x0000000000009060
xul!gfxD2DSurface::operator=+0x00000000000086C2
xul!gfxWindowsNativeDrawing::operator=+0x000000000021C3FA
xul!XRE_main+0x0000000000002B48
0x0000000000402532
0x0000000000401CCE
0x00000000004075B6
0x000000000040740D
kernel32!ProcessIdToSessionId+0x0000000000000209

This happens in docshell/base/crashtests/432114-2.html <http://tinderbox.mozilla.org/showlog.cgi?tree=Firefox&errorparser=unittest&logfile=1276069732.1276070356.20912.gz&buildtime=1276069732&buildname=WINNT%205.2%20mozilla-central%20debug%20test%20crashtest&fulltext=1#err0>

Comment 1

8 years ago
I can reproduce locally, using a Mac build I downloaded from Tinderbox.

./rundomfuzz.py build build/tests/reftest/tests/docshell/base/crashtests/432114-2.html

###!!! ASSERTION: Someone forgot to call EndUpdateViewBatch!: '!mRootVM', file ../../dist/include/nsIViewManager.h, line 296

nsCOMPtr<nsIViewManager>::operator->() const [nsIViewManager.h:297]
nsEditor::CreateTxnForDeleteSelection(short, EditAggregateTxn**, nsIDOMNode**, int*, int*) [editor/libeditor/base/nsEditor.cpp:172]
nsPlaintextEditor::Rewrap(int) [editor/libeditor/text/nsPlaintextEditor.cpp:123]
nsHTMLEditor::AddRef() [editor/libeditor/html/nsHTMLEditor.cpp:228]
nsEditor::Release() [editor/libeditor/base/nsEditor.cpp:211]
nsHTMLEditor::Release() [editor/libeditor/html/nsHTMLEditor.cpp:238]
nsCOMPtr_base::assign_with_AddRef(nsISupports*) [nsCOMPtr.cpp:82]
nsCOMPtr<nsIRDFDelegateFactory>::operator->() const [nsCOMPtr.h:888]
nsBaseCommandController::DoCommandWithParams(char const*, nsICommandParams*) [embedding/components/commandhandler/src/nsBaseCommandController.cpp:185]
nsCommandManager::DoCommand(char const*, nsICommandParams*, nsIDOMWindow*) [embedding/components/commandhandler/src/nsCommandManager.cpp:272]
nsHTMLDocument::ExecCommand(nsAString_internal const&, int, nsAString_internal const&, int*) [content/html/document/src/nsHTMLDocument.cpp:3781]
NS_InvokeByIndex_P [xpcom/reflect/xptcall/src/md/unix/xptcinvoke_unixish_x86.cpp:179]
CallMethodHelper::Invoke() [js/src/xpconnect/src/xpcwrappednative.cpp:3002]
CallMethodHelper::Call() [js/src/xpconnect/src/xpcwrappednative.cpp:2308]
XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode) [js/src/xpconnect/src/xpcwrappednative.cpp:2272]
XPC_WN_CallMethod(JSContext*, JSObject*, unsigned int, long*, long*) [js/src/xpconnect/src/xpcwrappednativejsops.cpp:1789]
js_Invoke [js/src/jsinterp.cpp:654]
js_Interpret [js/src/jsops.cpp:2158]
js_Invoke [js/src/jsinterp.cpp:664]
js_InternalInvoke [js/src/jsinterp.cpp:694]
JS_CallFunctionValue [js/src/jsapi.cpp:4634]
nsJSContext::CallEventHandler(nsISupports*, void*, void*, nsIArray*, nsIVariant**) [dom/base/nsJSEnvironment.cpp:2204]
nsGlobalWindow::RunTimeout(nsTimeout*) [dom/base/nsGlobalWindow.cpp:8631]
nsGlobalWindow::TimerCallback(nsITimer*, void*) [dom/base/nsGlobalWindow.cpp:8978]
nsTimerImpl::Fire() [xpcom/threads/nsTimerImpl.cpp:428]
nsTimerEvent::Run() [xpcom/threads/nsTimerImpl.cpp:521]
nsThread::ProcessNextEvent(int, int*) [xpcom/threads/nsThread.cpp:547]
NS_ProcessPendingEvents_P(nsIThread*, unsigned int) [nsThreadUtils.cpp:200]
nsBaseAppShell::NativeEventCallback() [widget/src/xpwidgets/nsBaseAppShell.cpp:127]
nsAppShell::ProcessGeckoEvents(void*) [widget/src/cocoa/nsAppShell.mm:395]
CoreFoundation + 0x3ef91
CoreFoundation + 0x3cbbf
CoreFoundation + 0x3c094
CoreFoundation + 0x3bec1
HIToolbox + 0x34f9c
HIToolbox + 0x34d51
HIToolbox + 0x34bd6
AppKit + 0x48a89
-AppKit + 0x482ca
-AppKit + 0xa55b
nsAppShell::Run() [widget/src/cocoa/nsAppShell.mm:747]
nsAppStartup::Run() [toolkit/components/startup/src/nsAppStartup.cpp:192]
XRE_main [toolkit/xre/nsAppRunner.cpp:3624]
main [browser/app/nsBrowserApp.cpp:158]
firefox-bin + 0x148e
Component: Graphics → Editor
QA Contact: thebes → editor

Comment 2

8 years ago
asserts(1-4) load 432114-1.html # bug 570215
asserts(0-2) load 432114-2.html # bug 570215, bug 571020
(Assignee)

Updated

8 years ago
Assignee: nobody → ehsan
(Assignee)

Updated

8 years ago
Keywords: testcase
(Assignee)

Comment 3

8 years ago
This is a symptom of bug 611798.  Duping against it.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 611798
You need to log in before you can comment on or make changes to this bug.