Need a way to compare UTF-8 strings in a case-insensitive manner

RESOLVED DUPLICATE of bug 145975

Status

()

Core
Internationalization
RESOLVED DUPLICATE of bug 145975
8 years ago
8 years ago

People

(Reporter: sdwilsh, Assigned: smontagu)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Right now we have no way to compare UTF-8 strings in a case-insensitive manner without converting both strings to UTF-16 first.  This is expensive if we have to do this a lot and/or with long strings.  #developers seems to think this is possible, so I've filed this bug.

Comment 1

8 years ago
Shouldn't this live in Core::XPCOM?
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> Shouldn't this live in Core::XPCOM?
Maybe?  Wasn't really sure where to put it.
(Assignee)

Comment 3

8 years ago
(see also bug 231782)
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 145975
(Reporter)

Updated

8 years ago
No longer blocks: 570975
You need to log in before you can comment on or make changes to this bug.