Can't double click on a bookmark in the sidebar.

VERIFIED WORKSFORME

Status

SeaMonkey
Bookmarks & History
P3
major
VERIFIED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Gilles Durys, Assigned: matt)

Tracking

({regression})

Trunk
x86
Windows 2000
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build 2000101720 Mtrunk

Double-clicking a bookmark in the sidebar does nothing.
(In the bookmark management windows, it's ok)

Comment 1

17 years ago
Same behavior observed on Linux Build ID: 2000101721

Comment 2

17 years ago
More info for Linux Build ID: 2000101721: In the console where mozilla was
started, the following appears each time a double click on a bookmark is attempted:

JavaScript error:
 line 0: clicked is not defined

JavaScript error:
 line 0: clicked is not defined

Comment 3

17 years ago
This was not the case in 2000101704 on Win2K.  I downloaded 2000101720 and I see
the sympoms described.  This seems to be a very recent regression.  I found bug
56574 doing a Tinderbox query that was related to a bookmark in the sidebar fix.
 Don't know if this caused this regression or not.

As a side note, neither Mozilla or IE bookmarks work (56574 was a fix to IE
bookmarks in the sidebar).
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

17 years ago
Changing OS to all per precedent comments.
OS: Windows NT → All

Updated

17 years ago
Keywords: regression

Comment 5

17 years ago
Just downloaded and installed Linux Build ID: 2000101809, and this problem is
gone (my previous build was 2000101721).

Comment 6

17 years ago
let's close it then.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 7

17 years ago
Still dead with 2000101808 on Win2k.
Reopening and changing OS.
Status: RESOLVED → REOPENED
OS: All → Windows 2000
Resolution: WORKSFORME → ---

Comment 8

17 years ago
This problem has returned on trunk linux, mac and win32 build 10/18
I have noticed this problem since I can remember when trying to view Imported 
IE Favorites in the Sidebar -- It opens the .lnk file in the browser like a 
text file and displays it in the main window such as:

[DEFAULT]
BASEURL=http://www.mozillazine.org/
[InternetShortcut]
URL=http://www.mozillazine.org/
Modified=60BD251BB81DC001F3
IconFile=http://www.mozillazine.org/favicon.ico
IconIndex=1

Native Moz links used to work fine. If this is an unrelated issue, sorry for 
the noise but I figured I'd toss in my $0.02.

Comment 10

17 years ago
This was bug 56574.  The fix was checked in on 10/17 at 15:39 by matt@netscape.com

I'm also unsure if it is realted or not, but am eager to find out.

Comment 11

17 years ago
Installed Linux Build ID: 2000101814 (working at home now) and this problem is
back again!

Comment 12

17 years ago
Can you all please note whether you're working with a -MN6 build or a -M18
build? I'm thinking we're seeing a "works on branch, broken on trunk" situation
here. Indeed, the patch checked in for bug 56574 broke this (trunk only), I
attached a patch which fixes it (only just now found this bug). Marking this
depending on that bug..
Depends on: 56574

Comment 13

17 years ago
*** Bug 57288 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
Peter, other than at d/l time is there a way to know if your build is branch or
trunk?  I have a tendency to pull from /latest where there is no d/l time indicator.

Comment 15

17 years ago
bookmarks: claudius
Component: Sidebar → Bookmarks
QA Contact: shrir → claudius

Comment 16

17 years ago
We're working on making it easier to find out, for what it's worth.

Currently there is no easy way to do so though :-( For the purpose of reporting
bugs, as long as there is the NS 6.0 (branch) / mozilla 0.6 (trunk) split, it's
best to keep track of it by downloading from a labelled directory instead of
latest/, though I believe work is under way to make it so that only trunk builds
go in latest/, which also kinda solves this problem :-)
(Reporter)

Comment 17

17 years ago
wfm with build 2000101920 trunk on Win98

Comment 18

17 years ago
Actually, "fixed". matt checked the fix in.
Resolving WFM in 20001020 W95.

Gerv
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 20

17 years ago
Verified Fixed on Mozilla trunk builds
linux 102009 RedHat 6.2
win32 102004 NT 4
mac 102008 Mac OS9
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.