Text overlaps the Floated image <img without width and height attributes by the first load

RESOLVED DUPLICATE of bug 546048

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 546048
8 years ago
8 years ago

People

(Reporter: Wael Elbanna, Unassigned)

Tracking

({regression})

1.9.2 Branch
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 GTB7.0 (.NET CLR 2.0.50727)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 GTB7.0 (.NET CLR 2.0.50727)

The text overlaps the cover image on the right by the first load of the page but by (reload or back/forwards) the same page it will be fine.

This case appears only by using Mozilla Firefox 3.6.3 but it appears good by the earlier versions and the other browsers.

<img src="image.jpg" width="" height="">

The "width" and "height" attributes are missing in <img element, these attributes are optional but recommended - according to W3 Recommendations - as they help the browser arrange the page properly by reserving space for the image as it constructs the page.

W3 Recommendations:
"The height and width attributes give user agents an idea of the size of an image or object so that they may reserve space for it and continue rendering the document while waiting for the image data."
http://www.w3.org/TR/REC-html40/struct/objects.html#adef-height-IMG 

But the question is, why it happens only by using this version (3.6.3) only.

This enforces me to embed these attributes for all images.

Could you fix it to avoid this conflict and make Firefox more reliable.

Reproducible: Always
(Reporter)

Updated

8 years ago
Severity: normal → major
works on 1.9.1, fails on 1.9.2, works on 1.9.3/trunk
Severity: major → normal
Component: General → Layout
Keywords: regression
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → 1.9.2 Branch
This worksforme on 1.9.2 as well (on Mac).  Someone who can reproduce should hunt down the regression/fix ranges if they care...
rough range for a start:
fails: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1) Gecko/20100208 MozillaDeveloperPreview/3.7a1 (http://hg.mozilla.org/mozilla-central/rev/43e818c28059)

works: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a2) Gecko/20100228 MozillaDeveloperPreview/3.7a2 (http://hg.mozilla.org/mozilla-central/rev/7b97c72399a0)

changelog: https://bugzilla.mozilla.org/buglist.cgi?resolution=FIXED;query_format=advanced;bug_status=RESOLVED;bug_status=VERIFIED;target_milestone=Firefox%203.7a2;target_milestone=mozilla1.9.3a2

gonna narrow down further when i have some more spare time.
Keywords: regressionwindow-wanted
Pushlog for that range:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=43e818c28059&tochange=7b97c72399a0
XtC4UaLL, which 1.9.2 build did you test?  Was it a current branch nightly, or a release?  Could this be bug 546048 ?
TBH, 1.9.2.4 build 6 release. gonna retest with a nightly build later at home.
Ah, ok.  Bug 546048 is fixed for 1.9.2.5 or later, fwiw.
ok, this was fixed on 1.9.2 within
http://hg.mozilla.org/releases/mozilla-1.9.2/pushloghtml?fromchange=1abd6c14ada1&tochange=869990a16d06 what indeed points to Bug 546048.

@Wael: your issue will be fixed in Firefox 3.6.6 (as there won't be a 3.6.5) in a few weeks.
you can check out the release date on https://wiki.mozilla.org/Releases to get to know when it's due to be released.
Keywords: regressionwindow-wanted
XtC4UaLL, thanks for double-checking that!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 546048
You need to log in before you can comment on or make changes to this bug.