Application update doesn't fallback from partial to complete download correctly

RESOLVED DUPLICATE of bug 538533

Status

()

--
critical
RESOLVED DUPLICATE of bug 538533
9 years ago
8 years ago

People

(Reporter: standard8, Unassigned)

Tracking

1.9.2 Branch
All
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
We saw this yesterday with Thunderbird off the 1.9.2.4 branch when we got a bit of a release wrong.

STR:
1) Have an update being offered with:
- a partial mar that has an invalid sha512 sum in the update xml
- a complete mar that is valid.

2) Check for updates and accept update offer
=> Partial mar is downloaded, message is presented with the fact that checking the integrity failed.
=> Complete mar is then automatically downloaded
=> Complete mar gets to 100%, then doesn't do anything.
=> Restarting in this state doesn't do anything

Application update completely broken until you nuke the updates directory or uninstall & reinstall.

On the error console (I had logging on) I could see that the complete mar was downloaded completely, then there was an error about this.update being null, it was located here:

http://hg.mozilla.org/releases/mozilla-1.9.2/annotate/9716c797df5b/toolkit/mozapps/update/src/nsUpdateService.js.in#l2499

I think that may explain why the update didn't finish up correctly.
Mark, I fixed this on trunk and planned to backport it to 1.9.2.x but the OOPP release took precedence along with a few other things getting in the way so it hasn't been backported yet. Can you or someone else verify this works on Thunderbird trunk?

Fixed by a general rewrite in bug 530872 though it needed a followup fix in bug 554561.

btw: there is even a test for this on trunk... half-hearted yeah
http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/update/test/chrome/test_0083_error_patchApplyFailure_partial_complete.xul
Bug 530872 and Bug 538533 fixed this bug on trunk. I just finished up a patch to backport this and other fixes and will mark Bug 538533 as fixed 1.9.2.x if / when it lands on 1.9.2.x so marking duplicate of Bug 538533
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 538533
You need to log in before you can comment on or make changes to this bug.