Add a shadow to the pointer cursor on MacOS X

RESOLVED WORKSFORME

Status

()

Core
Widget: Cocoa
--
minor
RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: Daniel Spiewak, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

When mousing over links, the cursor changes to a pointer hand.  This is expected behavior.  However, the pointer cursor is slightly different from the native Cocoa pointer hand.  This can be seen by viewing a web page in Safari (or Chrome, actually) and in Firefox 3.6.  Mouse over a link in both browsers.  The native pointer (in Safari or Chrome) has a slight shadow and is somewhat anti-aliased, while the pointer in Firefox has no shadow and has visibly-jagged lines.  This is a subtle disruption to the user experience and makes Firefox feel less like a native Mac application.

Reproducible: Always

Steps to Reproduce:
1. Mouse over a link

Actual Results:  
Cursor was not the native pointer.


I'm not sure why Firefox *isn't* using the native pointer.  It's just another "papercut" that undermines the user experience in a subtle and almost imperceptible way.

Updated

8 years ago
Component: Theme → Widget: Cocoa
Product: Firefox → Core
QA Contact: theme → cocoa
In fact, Firefox *is* using the native cursor ([NSCursor pointingHandCursor]). Webkit uses a custom image: http://trac.webkit.org/export/60969/trunk/WebCore/Resources/linkCursor.png

Still, theirs looks nicer, it would be good to use it.
(Reporter)

Comment 2

8 years ago
Interesting.  I didn't realize that WebKit was being nonstandard.  It's sort of an interesting philosophical question then: is it better to be strictly native (as WebKit *should* be), or blend a bit better with user expectations and use the non-standard pointer?

Comment 3

8 years ago
What license are these images under? Nothing we could use, I expect.
(Reporter)

Comment 4

8 years ago
WebKit's licenses are...complex.  Bits of it are GPL, bits are LGPL and some very tiny bits are BSD.  They don't seem to specify which license applies to the images, but I would assume the worst and guess GPL (which we can't use).

I also noticed that Colloquy uses the same "enhanced" cursor, but its UI is quite certainly licensed under GPL, so that's a no-go.  I don't know any other products off-hand which use the cursor, but it might be worth digging a bit.  There's an outside possibility that WebKit's images *are* BSD licensed, but I can't confirm or deny it at present.
Gerv, do you know if we're allowed to import that image from Webkit?

If we're not, we can just add the drop shadow ourselves... though we'd need the shadow-less hand cursor as an image first, for example from here:
http://developer.apple.com/mac/library/documentation/cocoa/reference/ApplicationKit/Classes/NSCursor_Class/Reference/Art/point_hand.gif
... and then we'd have the same problem.
The repo itself doesn't make it clear what is under what license. Wikipedia says that "WebCore" is LGPLed, and this cursor:
http://trac.webkit.org/export/60969/trunk/WebCore/Resources/linkCursor.png
is in the WebCore directory, so without any more specific guidance we'd have to assume it was LGPLed.

At the moment, we don't take LGPL-only code into the tree. :-|

If someone were to find a way of freeing or BSD-ing the cursor image, we could take it.

Here's the bug:
https://bugs.webkit.org/show_bug.cgi?id=11112
You could ask the guy who made it if he'd be willing to license the updated cursor to us... But it was probably based on the previous cursor, which was originally a TIFF, which was checked in 8 years ago:
http://trac.webkit.org/browser/trunk/WebCore/Resources/linkCursor.tiff?rev=10000
"haircut" may well be the code name for some Apple release.

So the copyright in the original icon probably belongs to Apple, and because it's in WebCore, it's probably LGPL.

Gerv
Thanks Gerv!

(In reply to comment #6)
> So the copyright in the original icon probably belongs to Apple

Does that mean that we would have to ask Apple directly to free the image?
Markus: unless you can prove either that it's under the BSD licence or that someone else is the copyright holder, yes.

Gerv
Summary: Non-Native Pointer Cursor on MacOS X 10.6 (Snow Leopard) → Add a shadow to the pointer cursor on MacOS X

Comment 9

8 years ago
I've reached out to Apple about this.
(Reporter)

Comment 10

6 years ago
This has been fixed in some recent builds (I believe in 8, but definitely in 9).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
I don't think it was fixed in Firefox but rather in Mac OS X.
(In reply to Markus Stange from comment #11)
> I don't think it was fixed in Firefox but rather in Mac OS X.

That would be a 10.7-only fix then. Recent nightlies on 10.6.8 have the same cursor as always.
You need to log in before you can comment on or make changes to this bug.