Closed Bug 571248 Opened 12 years ago Closed 12 years ago

Undo the removal of a personas doesn't remove undo listbox entry

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla2.0b3

People

(Reporter: whimboo, Unassigned)

References

Details

(Whiteboard: [AddonsRewrite])

Attachments

(1 file)

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a5pre) Gecko/20100610 Minefield/3.7a5pre

If you undo the removal of a Personas, the undo box doesn't get removed. If we remove the same Personas again another undo box will appear in the list.

We should only show one box and also remove it once the removal has been reverted.
Attached image screenshot
Surprised undo works for lightweight themes, given bug 553494.
Well, that's what I see. :) Looks like it can't be too hard to implement for all types? Anyway, even with bug 553494 in place we will have to wait for bug 553494 for further checks on this bug.
Depends on: 553494
Duplicate of this bug: 573843
Duplicate of this bug: 573457
Duplicate of this bug: 578170
Duplicate of this bug: 581101
Duplicate of this bug: 581129
Fixed by bug 553494
Status: NEW → RESOLVED
Closed: 12 years ago
Flags: in-testsuite+
Flags: in-litmus-
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b3
Status: RESOLVED → VERIFIED
Verified on :
Mozilla/5.0 (Windows; Windows NT 6.0; rv:2.0b3) Gecko/20100805 Firefox/4.0b3

and

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b3) Gecko/20100805
Firefox/4.0b3
You need to log in before you can comment on or make changes to this bug.