###!!! ASSERTION: How can the mouse be over a window but not over a view in that window?

RESOLVED DUPLICATE of bug 560766

Status

()

RESOLVED DUPLICATE of bug 560766
9 years ago
6 years ago

People

(Reporter: bzbarsky, Unassigned)

Tracking

({assertion})

Trunk
x86
Mac OS X
assertion
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

I get the assertion in the summary, like so:

###!!! ASSERTION: How can the mouse be over a window but not over a view in that window?: 'view', file /Users/bzbarsky/mozilla/css-frameconst/mozilla/widget/src/cocoa/nsChildView.mm, line 6237

with rev f2070673fdbc.

Steps to reproduce, as far as I can tell:

1)  Start some other Firefox.  Go to a bugzilla attachment patch and click the
    "Browse" button.
2)  Start a debug Firefox build.
3)  Click on the window the filepicker was posed from in step 1.
4)  Click on the window that opened in step 2.  Move it so it partially
    overlaps the filepicker, with its top edge cutting across the filepicker.
5)  Move mouse quickly to be over the filepicker.

Step 5 is when I see the assert.
(Reporter)

Updated

9 years ago
Keywords: assertion
Dupe of bug 560766 (or vice-versa; not clear which bug has more/better info)?

Comment 2

6 years ago
As mentioned in Bug 560766 Comment 3, Bug 675208 removed the assertion.

So I guess it doesn't really matter now - I'll mark this newer bug as the dupe.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 560766
You need to log in before you can comment on or make changes to this bug.