Closed Bug 571477 Opened 10 years ago Closed 2 years ago

Remove modal dialog for 'About <addon>' in favor of placing in-content

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1311145

People

(Reporter: Tobbi, Assigned: jboriss)

References

Details

(Whiteboard: [AddonsRewriteTestday][AddonsRewrite])

When you right-click on an add-on in the new add-ons manager, then select 'About <add-on>', a modal dialogue pops up. 

We should change this to a pane in the add-ons manager as to remove the modal dialogue.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Lets get this onto the uiwanted list.
Keywords: uiwanted
OS: Mac OS X → All
Hardware: x86 → All
Summary: Change 'About <addon>' dialogue → Remove modal dialog for 'About <addon>' in favor of placing in-content
What's the justification for this?

Note there are 2 types:
- default
- user provided via em:aboutURL
Assignee: nobody → jboriss
Keywords: uiwanted
See Also: → 1139182
(In reply to Brian King [:kinger] from comment #2)
> What's the justification for this?

It's better to have a central place for information related to an add-on.

> Note there are 2 types:
> - default
> - user provided via em:aboutURL

There was some discussion about customized about dialogs in bug 1139182. It needs to be decided whether to keep that feature or not. Getting stats from mxr about how many add-ons actually make use of this may help. (Though mxr is down at the moment.)

Sebastian
(In reply to Sebastian Zartner [:sebo] from comment #3)
> There was some discussion about customized about dialogs in bug 1139182. It
> needs to be decided whether to keep that feature or not. Getting stats from
> mxr about how many add-ons actually make use of this may help. (Though mxr
> is down at the moment.)

https://dxr.mozilla.org/addons/search?q=em%3AaboutURL&redirect=false returns 4,783 matches. So, custom about dialogs are obviously (surprisingly) pretty common and therefore needs to be considered.

Sebastian
Note that if bug 1311145 lands, then this bug will become irrelevant.
See Also: → 1311145
I don't think there is any plan to change what is already in about:addons. As Andy mentioned this will be fixed by Bug 1311145.

There is a patch there and I think this has no objections to land :).
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1311145
You need to log in before you can comment on or make changes to this bug.