when replying to a non-format=flowed message, conversion to f=f mangles spacing in the middle of a line

RESOLVED DUPLICATE of bug 448198

Status

Thunderbird
Message Compose Window
--
major
RESOLVED DUPLICATE of bug 448198
8 years ago
6 years ago

People

(Reporter: Paolo Bonzini, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100403 Fedora/3.6.3-4.fc13 Firefox/3.6.3
Build Identifier: 

When I reply to a message that includes code, the spacing around several characters (including < > &) is changed incorrectly while quoting the message.

The same behavior doesn't happen if I use the "Paste as Quote" menu item.

Reproducible: Always

Steps to Reproduce:
1. Save the attachment to a file
2. Open it using File/Open/Message
3. Notice it says "version_id >= 11"
4. Click "reply"
Actual Results:  
The first line in the reply will be:

> +	if (version_id>= 11) {

without a space before the greater-than sign.

Expected Results:  
Spacing should be kept as it was.

A possible workaround could be to copy the text before hitting reply and do Select All/Paste As Quote (Ctrl-A/Ctrl-Shift-O) after.  This way the quotations are not mangled.  However, this is unacceptable in general, as it removes the "On ..., XYZ wrote:" line from the message.

I'm marking it as major because it occurs many times a day when working on projects that use email and mailing lists for code reviews.
(Reporter)

Comment 1

8 years ago
Created attachment 450654 [details]
minimal testcase
(Reporter)

Comment 2

8 years ago
BTW, it is not restricted to message/rfc822 files, it's just a handy testcase.
Paolo what you think about bug #534068? Could be basically this a duplicate of him (even if you do you mean "reply")?
(Reporter)

Comment 4

8 years ago
Created attachment 454848 [details]
adding f=f hides the bug

It is somewhat related to format=flowed:

1) setting mailnews.send_plaintext_flowed to false is a workaround for this bug.

2) the bug only occurs if the message is _not_ in format=flowed.  This second attachment is the same as bug.eml, but has f=f encoding and is not mangled.

However no, it's not the same.  In this bug, the problem occurs already when the message is quoted in the compose window, not when they are sent.  The compose window shows exactly what will be sent, and it is wrong.  If you fix it in the window it will be sent correctly.

It appears that this bug is due to excessive zeal in converting non-format=flowed messages to f=f.  I'll change the subject accordingly.
(Reporter)

Updated

8 years ago
Summary: using "reply" on a message that contains code mangles the spacing → when replying to a non-format=flowed message, conversion to f=f mangles spacing in the middle of a line
(Reporter)

Updated

8 years ago
Blocks: 168420
(In reply to comment #4)
> Created an attachment (id=454848) [details]
> adding f=f hides the bug
> 
> It is somewhat related to format=flowed:
...then could be a dupe of bug #204478 ? Paolo your thoughts ? ;-)
(Reporter)

Comment 6

8 years ago
No, I _do_ want to send f=f even though I'm replying to non-f=f.
(Reporter)

Updated

7 years ago
OS: Linux → All
Hardware: x86 → All
(Reporter)

Updated

7 years ago
Version: unspecified → 3.1
(Reporter)

Comment 7

7 years ago
Still fails in Thunderbird 5.0.  Can anybody confirm this?

Comment 8

6 years ago
Discussion on http://groups.google.com/group/mozilla.dev.apps.thunderbird/browse_thread/thread/1ba805b10a6369c1# might be relevant for this bug.
(Reporter)

Comment 9

6 years ago
Still fails in 10.0.
(Reporter)

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Keywords: common-issue?, reproducible, testcase
Resolution: --- → DUPLICATE
Duplicate of bug: 448198
Keywords: common-issue?, reproducible, testcase
You need to log in before you can comment on or make changes to this bug.