Pop-up blocker should provide more options.

RESOLVED WORKSFORME

Status

()

Firefox
General
--
enhancement
RESOLVED WORKSFORME
8 years ago
4 years ago

People

(Reporter: Valdis Kletnieks, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.3a5pre) Gecko/20100609 Minefield/3.7a5pre
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.3a5pre) Gecko/20100609 Minefield/3.7a5pre

Visit the URL.  There's a Youtube Flash on the page. Right-click inside it (at least on the Linux Flash plugin), get the Flash menu, and select 'Watch on Youtube'.

This results in a "Minefield prevented this site from opening a pop-up window" titlebar, that has a menu button "Preferences", with the following choices:

"Allow pop-ups from crooksandliars.com"
"Edit Pop-up Blocker Preferences"

Notably absent - an option to allow *this* *one* pop-up to happen, but retain the general blocking. Currently, my selecting 'Allow' for an *intended* pop-up that I specifically requested because I clicked on it means that I'm at the mercy of any future rogue Javascript/etc that may happen on that page.

Recommendation:  Change 'Allow pop-ups from' to two choices "Allow this pop-up from" and "Allow all pop-ups from".

Reproducible: Always

Comment 1

8 years ago
Confirming on Windows XP Firefox 3.6.8

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 ( .NET CLR 3.5.30729)


Right clicking an embedded YouTube video on a web page and selecting 'Watch on
Youtube' from the pop-up menu triggers the pop-up blocked bar, but the Options button has no "Show '<the URL of the pop-up>'" item, like it does with most other blocked pop-ups.

Comment 2

8 years ago
Sorry, I encountered the issue on Vista, not XP.

Comment 3

6 years ago
do you still reproduce this using a current version?

I'm having trouble with the website. Perhaps it changed?
Flags: needinfo?

Comment 4

4 years ago
Could not reproduce issue and no response to request for more info.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.