browser_library_middleclick.js may leave an open tab, breaking following tests

RESOLVED FIXED

Status

()

Toolkit
Places
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: mayhemer, Assigned: mayhemer)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Created attachment 450674 [details] [diff] [review]
v1 [Checking comment 2]

The fix has been privately approved by Marco (CC'ed).

This issue appears more often with patch for bug 513086 applied making the test suite often orange.  However, this failure is not caused by patch for that bug.
Attachment #450674 - Flags: review+
typo: "If not inluded"
(Assignee)

Comment 2

8 years ago
Comment on attachment 450674 [details] [diff] [review]
v1 [Checking comment 2]

http://hg.mozilla.org/mozilla-central/rev/50afb11d3425
Attachment #450674 - Attachment description: v1 → v1 [Checking comment 2]
(Assignee)

Comment 3

8 years ago
(In reply to comment #1)
> typo: "If not inluded"
Fixed during checkin.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

8 years ago
And for reference: the failing test was chrome://mochikit/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_beforeunload.js

I don't recall exactly the test, but it probably was "The middle tab should be the same one we opened"
You need to log in before you can comment on or make changes to this bug.