firefox hangs in "futex wait" state

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: ken, Unassigned)

Tracking

({hang})

3.6 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

Firefox hangs (almost) completely. Oddly enough - at least to me, is that the window will minimize and restore, but it won't repaint itsef. I another window is above it then removed, the visual contents are still within the firefox window.

When this happens, I open gnome-system-monitor, and it shows firefox in a "futex wait" state. This is always the case!

I have tried to see if there are any correlations to specific apps or actions, but it does seem very random, although it a tab is loading, and you try to scroll or open a menu, or even switch to a different tab, this seems to cause the problem a lot, but on some occasions, this has happened when sending the tab to a new URL.

FWIW: I typically have two or three tabs open, and I know at least one of them auto-refreshes ads on it.

Reproducible: Always

Steps to Reproduce:
1.No specific steps to reproduce. very inconsistent, but quite frequent.
2.
3.
Actual Results:  
see details section. But do note that it is in a "futext wait" state.

Expected Results:  
firefox to continue to repaint itself and reload a page

I do have cool-previews running, but I get the same problem with or without it.
What website is this that causes the hang? Try safe mode. http://support.mozilla.com/en-US/kb/Safe+mode
Severity: critical → major
Keywords: hang
Version: unspecified → 3.6 Branch
(Reporter)

Comment 2

8 years ago
no specific site. It is very inconsistent concerning when it happens. But it does frequently.
(Reporter)

Comment 3

8 years ago
quick update:

I tried safe mode. Same results. Several times.

I do have a periods of large data transfers through my wan - but not on the same subnet as I am running firefox. This does slow down firefox dramatically, fetching pages, as well as sending data. I occasionally get a "disconnected" or "cannot contact to site" message page due to traffic delays. Maybe firefox gets into a deadlock waiting for a response while trying to do some gui thing (which is typically when it freezes)? This is just a guess, though. 

FWIW: this does happen quite frequently to me, at least once a day.
(Reporter)

Comment 4

8 years ago
This problems appears to have been corrected in the latest release:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6

I have been using this for awhile, and no futext dead-locks.

CoolPreviews add-on does seem to slow the entire app down - I notice this when there are already several tabs open. But no errors.

I will leave the status unchanged. Any of you firefox-er's can change it to "resolved" if you feel it is.

I didn't see any other comments on this, but I do thank you for whatever someone did to fix it :-).

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.