Closed Bug 571649 Opened 10 years ago Closed 10 years ago

Re-enable Docshell tests after Bug 535922

Categories

(Core :: DOM: Navigation, defect, blocker)

defect
Not set
blocker

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- final+

People

(Reporter: Callek, Assigned: jmaher)

References

Details

(Keywords: regression)

Attachments

(1 file)

Apon landing Bug 568733 (1d840cf822e6) I found that I had a nice large array of strange failures.

It turns out that re-enabling docshell tests caused 33 Mochi-Browser-Other failures; Plus "Leaked The World"

Bz told me to assign to jmaher, and request blocking.

Backing out right after I submit this bug
Disabled the tests in changeset 1b3956e909dd
Keywords: regression
Fixed some obvious bugs in browser_bug554155.js:
http://hg.mozilla.org/mozilla-central/rev/c8929de36eb2
Blocks: 535922
No longer depends on: 535922, 568733
:callek, I don't understand the problem?  Is it that these tests were disabled before my original patch landed?  Is it that they were running both before and after my patch, but as a result of my patch they started failing?  

I need to figure out what is the expected behavior here and what changed (besides what is obvious from the patch) before fixing anything.  Please point me to bugs of the failures as well.  Also I don't see failures related to this on tinderbox (via tbpl for m-c and try server)
Joel, you disabled these tests wholesale for all builds, including Firefox ones, in your patch for bug 535922.  They were passing at the time.  When Justin tried to clean up after you and reenable the tests in bug 568733, he discovered that in the intervening 4 weeks some of the tests have started failing due to not actually running when checkins happen.  The problem is that these tests need to be running.  So someone needs to figure out why they're failing now, fix that, and reenable the tests.
thanks for the clarification
this is odd, I added 'browser' back into the dirs list and ran it locally with no errors.  Then I did a try server run and there were no errors.

Is there something else I should do to see the errors?  Can I have a list of test cases (filenames) that cause failures so I can investigate what changed?
Maybe browser_bug554155.js was the only problem and http://hg.mozilla.org/mozilla-central/rev/c8929de36eb2 fixed it.
I looked at your try changeset just to ensure that the tests were correctly re-enabled, they were. I think it is safe to say the only problem was browser_bug554155.js.
this turns on the browser-chrome tests for docshell.  It appears that there was only 1 test file that was problematic and that has changed since discovering these tests were turned off.  In a try server run and local runs all these tests pass.
Attachment #451081 - Flags: review?(bugspam.Callek)
Comment on attachment 451081 [details] [diff] [review]
turn on the docshell browser-chrome tests 

r=dbaron

I'd also note that the commenting method that this removes is actually not correct commenting, because the $(NULL) is actually not part of the DIRS += line, since the lines in between aren't continued.
Attachment #451081 - Flags: review?(bugspam.Callek) → review+
(In reply to comment #10)
> I'd also note that the commenting method that this removes is actually not
> correct commenting, because the $(NULL) is actually not part of the DIRS +=
> line, since the lines in between aren't continued.

O whops, thanks :/
Landed as 86a1dfc93d39
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
blocking2.0: ? → final+
You need to log in before you can comment on or make changes to this bug.