Already retrieved email (POP) gets retrieved again after detaching the attachment from the email on the ISPs server

RESOLVED INVALID

Status

RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: Nomis101, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [has protocol log])

Attachments

(1 attachment)

102.69 KB, application/zip
Details
(Reporter)

Description

9 years ago
If your available storage space for emails is limited to a small size from your ISP, than you sometimes need to detach large attachments from an email. If you do so, than this email is recognized from Thunderbird as a new email and get retrieved again.

STR:
1. Retrieve an email with an attachment (in my case from web.de via POP)
2. Go to your ISPs website and login to your webmail account
3. From the retrieved email detach the attachment
4 [review]. Retrieve your emails with Thunderbird
--> Thunderbird tells you about a new email, but this is the email you already retrieved, but now without the attachment

Expected: TB should know that this is the email that is still in the inbox and not retrieve it again


Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; de; rv:1.9.3a6pre) Gecko/20100611 Thunderbird/3.2a1pre
Can you provide a pop log https://wiki.mozilla.org/MailNews:Logging ?
Component: General → Networking: POP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.pop
(Reporter)

Comment 2

9 years ago
Created attachment 452250 [details]
pop log

(In reply to comment #1)
> Can you provide a pop log https://wiki.mozilla.org/MailNews:Logging ?

Yes. This are two log files. pop3_1.log is the log file for retrieving the mail the first time (with the attachment). And pop3_2.log is the log file for retrieving this mail the second time after I detached the attachment (after logging in to web.de webmail directly).

Comment 3

8 years ago
duplicate of Bug 554305 - detaching attachment downloads message twice ?

// related to Bug 305990 - Deleting/detaching attachments resets return receipt status - cause mdn to be sent twice ?
(Reporter)

Comment 4

8 years ago
(In reply to comment #3)
> duplicate of Bug 554305 - detaching attachment downloads message twice ?
I'm not sure, Bug 554305 is about detaching in Thunderbird. This is about detaching on the ISPs server. But its related.

Updated

8 years ago
Whiteboard: [has protocol log]

Comment 5

8 years ago
I suspect from the server this just looks like a completely new pop3 message to thunderbird, in terms of UIDL's. And in fact, the messages have two different UIDLS according to the pop3 protocol log, and as far as Thunderbird knows, those are two different messages.  see 333 1633013029 and 333 0Mb4WI-1Oe6Kk0xI3-00Kgza
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

8 years ago
OK, thanks for clarifying. But how can I solve this now? Or can't I solve it.

Comment 7

8 years ago
I don't think there's a solution for this - there are extensions to remove duplicates, but I think the big size difference between the two messages that are "the same" would discourage the duplicate detection code.
You need to log in before you can comment on or make changes to this bug.