Closed Bug 571755 Opened 11 years ago Closed 5 years ago

live.com - Windows Live thinks Minefield is a mobile phone

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: josh.tumath+bugzilla, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a6pre) Gecko/20100612 Minefield/3.7a6pre
Build Identifier: 

When I go to "http://www.live.com/", I am always redirected to "http://mobile.live.com".

Reproducible: Always

Steps to Reproduce:
1. Go to: http://www.live.com
2.
3.
Actual Results:  
You are redirected to mobile.live.com

Expected Results:  
You should stay in www.live.com
Blocks: geckoisgecko
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86_64 → All
Assignee: nobody → english-us
Component: General → English US
Product: Core → Tech Evangelism
QA Contact: general → english-us
Josh, I believe this is a known issue with some server-side sniffers thinking that any UA string containing "pre" is a Palm Pre.  Please make sure to complain to the site operator?
(In reply to comment #1)
Will do.
I don't get redirected with UA string

> Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a6pre) Gecko/20100612 Firefox/3.7a6pre

though
Yeah, the sniffer looks for "firefox" (or equivalent; when I experimented with some similar sites "fire" worked too in some cases and the like) before it looks for "pre"...
Blocks: 576936
Well this is very typical of support websites. I tell them what the problem is, and I even tell them how to fix, and then it takes them 5 days for them to end up blaming you: the developers.

http://windowslivehelp.com/thread.aspx?postid=5D3429FF-0CF9-4D4D-A615-1F69F0C68821

I've been told that that help site is the only way to give feedback and report bugs. What should I do now?
Josh: You should probably point them here, because it's quite clear that

a) English is not the first language of at least two of their "support" people; and
b) they are not understanding what the problem is at all.

We don't have any contacts at Microsoft, do we?
Oh. I should have realised that. I'm not really sure what else I can say, though. Support staff aren't developers, so I'm not really sure if I'm going anywhere with this. I'm don't know what I should say to them for them to have a better understanding of the problem.
Oh, we have contacts.  Chris might even know who they are!
And Josh, I'm not sure there's anything useful you can do here.  As you said, this is pretty typical for site support.  :(
Oh well. Hopefully bug 572650 will sort this out.
As you might expect, broken sniffing problems are pretty widespread across live.com properties (http://tinyurl.com/2wt7vuf) and across MS properties in general (don't have a handy search for that one).
Summary: Windows Live thinks Minefield is a mobile phone → live.com - Windows Live thinks Minefield is a mobile phone
Blocks: 582948
No longer blocks: 582948
Blocks: 582264
Can't they just change the "pre" to Beta or some other term?
Which "they"?  The "pre" in the Gecko user-agent means something different from a beta (e.g "2.0b4pre" is the current user-agent string).

Chances are that due to sites like live.com being idiots this way we'll have to remove the string "pre" from the UA, in fact, but it's been there for years with no problems until people started deploying broken sniffing code....
I guess the UA string will have to be changed with Windows Live Support being so ignorant and not looking further into this matter.... dumb broken UA string :(.

https://bugzilla.mozilla.org/buglist.cgi?field0-0-0=short_desc&type0-0-1=substring&field0-0-1=short_desc&value0-0-2=Microsoft%20Live&query_format=advanced&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&field0-0-2=short_desc&value0-0-1=Windows%20Live&type0-0-0=substring&value0-0-0=live.com&type0-0-2=substring&product=Tech%20Evangelism 

Most of those have the same/similar problem with the UA String :S Out of interest is it hard/very time consuming to change the String?
I'll reach out to the live.com people but a. stop calling them idiots (people make mistakes) and b. we need to wait until the final UA is in place since we're making a pile of other changes.
(In reply to comment #15)
> I'll reach out to the live.com people but a. stop calling them idiots (people
> make mistakes)

Assuming that anything containing the word "pre" is a Palm Pre, and using *only* the presence of the word "pre" to validate that assumption, is not a "mistake", at least not in the sense that "mistake" means "oops, I meant to type foo instead". I wouldn't go so far as to call it idiocy to their faces, but it's pretty freakin stupid. (And I think bz is well-qualified to call this behaviour whatever he bloody well pleases.)

I don't know what the UA string from a Palm Pre looks like, but I'm sure there's a reasonably simple way to tell the difference between it and a nightly build of any Mozilla product. Like, say, sniffing for "Gecko" instead, which would magically get them the proper behaviour in *all* Mozilla products.

http://geckoisgecko.info/

cl
Chris, I was careful to refer to the site, not the people.  As far as I can tell, they (and others) are using some sort of off-the-shelf library that's just broken...  A lot of sites seem to have the same broken behavior.
Fixed by placing Firefox in the trunk user agent, bug 588874.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Fixed for Firefox, not for other Gecko browsers....
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Moving to Desktop.
Which other gecko browsers are affected?
Assignee: english-us → nobody
Component: English US → Desktop
Just tried with Mozilla/5.0 (X11; Linux armv7l; rv:31.0) Gecko/20100101 Firefox/31.0 Iceweasel/31.2.0
got the desktop site.

I will close as FIXED. 
Though I think that mobile.live.com is not anymore existent. :)

If you have a specific bug about live.com domains
please open a bug on https://webcompat.com/
Status: REOPENED → RESOLVED
Closed: 11 years ago5 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.