Allow custom server URL to lack a trailing slash

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: leonardof, Unassigned)

Tracking

unspecified
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100402 Namoroka/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100402 Namoroka/3.6.3

If the custom server is https://example.com/weave/, and the user types https://example.com/weave, Firefox Sync client won't be able to find the server.

Reproducible: Always

Steps to Reproduce:
1. Set up a personal Weave server
2. Set up the client without the trailing slash
Actual Results:  
Firefox Sync doesn't find the server

Expected Results:  
Firefox Sync should find the server anyway. An extra slash doesn't kill anyone :)

Actually I tried this with a http:// address, because it's a home network.

Updated

8 years ago
Target Milestone: --- → 2.0
Yeah, this bug just absorbed an hour of my time because I was sitting there trying to remember my password (since I only need it once in a blue moon), and I tried pretty much every combination before suspecting that the server name was wrong.

It was only when I started trying every combination of server name username and passphrase, and expired all other possible options that it occurred to me that the slash might be important.

Ugh.
This was fixed a while ago. WFM now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.