[om-ET] [Fx] New localization: Oromo, Ethiopia

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
9 years ago
5 years ago

People

(Reporter: bemeodar, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

We recently localized OpenOffice.org to Oromo language and now want to localize Firefox to this language. Here is the detail

Product: Firefox
Language name: Oromo
Language code: om
Country code:ET
Locale name: om-ET

Contact:
       Name: Belayneh Melka
       E-mail: bemeodar@gmail.com

                 Thanks in advance


Reproducible: Always

Comment 1

8 years ago
Hi Belayneh,  Have you had a chance to review this document:

https://developer.mozilla.org/en/Create_a_new_localization

This will give you all the details on how to begin your work.  When you have completed the translation of the Firefox UI into Oromo, you will need to attach those files here for a review.  The documentation above should tell you how to get an ".XPI" of your complete work to attach here.

Once we get closer, you will want to import your work to our version control system that is called Mercurial (aka Hg).  Bit Bucket is a public sandbox where you can experiment with Hg, and that is also referenced in the above documentation.  We can create a Bit Bucket account for you when you are ready.

Before we go too far though, we really need to see your work in order to determine the best next step.  Sometimes, a locale will become an official build that is released by Mozilla.  Other times, it stays an an official language pack on our Addons website.  I wrote a blog post about that that is worth reading.

http://blog.mozilla.com/seth/2010/02/17/language-pack-vs-official-localization/

Comment 2

8 years ago
Hi Belayneh, have you had a chance to read the above comment 1?  It would be good for you to review the process in articulated in https://developer.mozilla.org/en/Create_a_new_localization

Comment 3

8 years ago
Hi Belayneh, I might close this bug and resolve it as incomplete.  It's not that I don't want you to work on Oromo translation, I do!  :)  But, I don't see much activity and I would like to do some bug triage to our queue.  If you would like to work on the project, no problem.  Just comment in this bug with your progress and reopen it.  We can move from there.  Does that seem clear?  Thanks and hope to hear from you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 4

8 years ago
Hi,

I was not clear on how to proceed. I didn't understand the document. But I am active on the translation work

Comment 5

8 years ago
Can you state where you are exactly with the work?  I wouldn't mind reading something about your progress.  Why you say you are active on the translation work, what are you doing?  Are you using a tool to help you translate?  Which part is hard to understand?
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INCOMPLETE → ---
(Reporter)

Comment 6

8 years ago
I am using Mozilla translator. The too is easy to use and am doing on it smoothly. What I didn't understand is how to make the translation installable so that people can use it to browse using Firefox in Oromo Language.

Comment 7

8 years ago
There's a bit of documentation on https://wiki.mozilla.org/L10n:MozillaTranslator, also a pdf userguide linked from there. Not sure how focused that is. Maybe Ricardo can help, he's owning MT these days.
(Reporter)

Comment 8

8 years ago
Thanks a lot for your help. By the way I have already translated more than 90%. So I need to build the translation into an executable format.
(In reply to comment #8)
> Thanks a lot for your help. By the way I have already translated more than 90%.
> So I need to build the translation into an executable format.


FWIW, MozillaTranslator can't build XPIs anymore, since its feature was designed for old XPFE applications, last of which was SeaMonkey 1.x. What I think is puzzling Seth, Axel and myself is: which starting point are you using to translate to om-ET? Have you used an en-US.jar file, or have you cloned the mozilla-central repository?
(Reporter)

Comment 10

8 years ago
Hi,

Thanks a lot for your response. I have used en-US.jar file. The tool I have used for translation is Mozilla translator.

  Thanks in advance
(In reply to comment #10)
> Thanks a lot for your response. I have used en-US.jar file. The tool I have
> used for translation is Mozilla translator.


I've been browsing MDN and digging into some langpack XPIs and JARs contents. I guess I could update MT to create JARs and XPIs when the origin is an en-US.jar file like your case, given a reference chrome.manifest and an install.rdf, but it will take me some time. In the meanwhile, it is not so difficult to create both files (JAR and XPI) manually. You can contact me privately (use my bugzilla e-mail address) so I help you to build it.

Since both Seth and Axel are following this bug, I pledge them some directions about the chrome.manifest content for a langpack. :-) Especially, I don't quite get how could I find out when override is to be used.
(Reporter)

Comment 12

8 years ago
(In reply to comment #11)
> (In reply to comment #10)
> > Thanks a lot for your response. I have used en-US.jar file. The tool I have
> > used for translation is Mozilla translator.
> 
> 
> I've been browsing MDN and digging into some langpack XPIs and JARs contents. I
> guess I could update MT to create JARs and XPIs when the origin is an en-US.jar
> file like your case, given a reference chrome.manifest and an install.rdf, but
> it will take me some time. In the meanwhile, it is not so difficult to create
> both files (JAR and XPI) manually. You can contact me privately (use my
> bugzilla e-mail address) so I help you to build it.
> 
> Since both Seth and Axel are following this bug, I pledge them some directions
> about the chrome.manifest content for a langpack. :-) Especially, I don't quite
> get how could I find out when override is to be used.

I am so happy that you help me on this and I am waiting for you to give some input.

Comment 13

8 years ago
I think the best way forward is for you to attach what you have, and I'll try to talk someone on our side into converting that to a directory structure that we can use going forward.

That directory structure is bound to what we have as source, it's used to create the xpi files that we used to ship. With firefox 4, we'll actually ship something else, even. That's why we need the files in the original setup, so that we can mangle and shuffle them as we please to include them in a shipping build. Also, from that directory structure, you'll be able to create language packs for testing quite easily, so it's a win-win.
For what I've seen, Belayneh is working on Firefox 3.6, and I think we're approaching to a functional XPI for testing (maybe today I can send him one). Migrating what he has to the Firefox 4.0 repository layout shouldn't be too hard with MozillaTranslator (it's not absolutely trivial, but I've done it before, and it is documented at [1]).

So, it is entirely up to you (Belanyeh and Axel) to choose the path that best fits you, but if you're comfortable with what I've outlined above (testing Fx3.6 and then upgrading to Fx4.0), I don't expect to cause us neither too many problems or workload. :-)

[1] https://wiki.mozilla.org/L10n:MozillaTranslator#Migrating_contents_when_the_directory_structure_changes

Best regards.
(Reporter)

Comment 15

8 years ago
I am comfortable to the outline Testing Fx3.6 and then upgrade to Fx4.0. So I am waiting for the XPI file so that I'll test soon.
I would just like to note for the record that 'om' (Oromo) is listed in the IANA Language Subtag Registry as a macrolanguage. Any attempted localization should be appropriate for all microlanguages within the scope of the macrolanguage. If this is not possible, please consider localizing an individual microlanguage instead.

These are the language tags currently within the scope of 'om':
gax = Borana-Arsi-Guji Oromo
gaz = West Central Oromo
hae = Eastern Oromo
orc = Orma
Summary: Want to Localize Firefox to Oromo Language → [om-ET] Want to Localize Firefox to Oromo Language
OS: Windows XP → All
Hardware: x86 → All
Summary: [om-ET] Want to Localize Firefox to Oromo Language → [om-ET] Localization Team Registration for Oromo, Ethiopia
Summary: [om-ET] Localization Team Registration for Oromo, Ethiopia → [om-ET] [Fx] New localization: Oromo, Ethiopia
Per CLDR replacement rules, if this localization is to use the 'om' language tag, it must represent the West Central Oromo language (otherwise represented by language tag 'gaz'), and vice versa.

http://unicode.org/repos/cldr/trunk/common/supplemental/supplementalMetadata.xml

Comment 18

6 years ago
Belayneh, If you send me your localization file. We can setup a new locale on pootle to continue your work.

http://mozilla.locamotion.org/
This locale registration bug is being resolved as INCOMPLETE because it has not been updated since before the final Firefox 17esr release on 2013-11-15. It is assumed that there has not been any progress in developing the desired localization since that time.

If you feel this bug has been closed in error, please reopen it and provide a status update for your locale.

In addition, please be sure to follow the guidelines listed on the wiki for creating a new localization:

https://wiki.mozilla.org/L10n:Starting_a_localization

[Mass change filter: l10n-new-incomplete-fx17esr]
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago5 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.