Update menulist look and feel to match new dialog style

RESOLVED DUPLICATE of bug 532677

Status

RESOLVED DUPLICATE of bug 532677
9 years ago
8 years ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

Details

(Assignee)

Description

9 years ago
Update the <menulist> popup to look more like the new contextmenu and prompt popups.  This means:

1. Update the menuitems styles to match the new dialog button styles.
2. Get rid of the "Done" button (selecting an item should dismiss the dialog immediately).
3. Keep the check marks (to indicate the current selection).
4. Let the user press back/escape, or tap outside the dialog to cancel (an easy way to keep the current selection).

This dialog also allows multiple selections, when it is used for HTML <select> elements because FormAssistant is disabled.  Maybe we should continue to use the old UI for that (rare) case.
Thinking of it, extensions developers probably want to have multiselect listbox too.

Can't we keep the blue glow active if the item is selected, so this will make possible to have multiple selections?
(Assignee)

Comment 2

9 years ago
Back/escape is fixed by bug 572716.
Depends on: 572716
(Assignee)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 532677
You need to log in before you can comment on or make changes to this bug.