Need to be able to build "embedding" separately from seamonkey

RESOLVED FIXED in Future

Status

SeaMonkey
Build Config
P3
normal
RESOLVED FIXED
18 years ago
13 years ago

People

(Reporter: dougt, Unassigned)

Tracking

Trunk
Future
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
We need the ablity to build the base embedding requirements from the mozilla
tree without having to build unneeded components such as seamonkey specific
bits, mailnews, ect.

Updated

18 years ago
Depends on: 57282
(Reporter)

Comment 1

18 years ago
I checked in a embed.mk files to the root level of mozilla.  This will build
just what is required by gtkEmbed.

Next step is for leaf to build gtkEmbed using this makefile instead of the
client.mk files.

Leaf, I am assigning this bug to you.  after doing your morning verification
builds, could you do a clobber_all then build gtkEmbed against this makefile?


Assignee: dougt → leaf

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 2

18 years ago
that's a negative, poppa bear. We need to keep the built tree around in case we
need to do depend build respins. We *could* do something along the lines of
producing an embedding build at an odd hour with a separate at job, though.
Thereby not requiring a separate build machine for embedding release stuff.

Unless, of course, you need builds done in a time-critical fashion, in which
case, we're going to need another release machine for embedding. Feedback welcome.
(Reporter)

Comment 3

18 years ago
These builds are not time critical (now).  Can you spin these builds before you
spin Seamonkey?

If equipment is a problem, let me know.

Comment 4

17 years ago
I could swear this is a dup of another bug to set up standalone embedding
builds, but I can't seem to find it.  marking future for now.
Target Milestone: --- → Future

Comment 5

17 years ago
*** Bug 62657 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Summary: Need to be able to build "embedding" seperately from seamonkey → Need to be able to build "embedding" separately from seamonkey

Updated

14 years ago
Assignee: leaf → cmp
Status: ASSIGNED → NEW
Product: Browser → Seamonkey

Comment 6

13 years ago
Mass reassign of open bugs for chase@mozilla.org to build@mozilla-org.bugs.
Assignee: chase → build

Comment 7

13 years ago
Fixed by xulrunner.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.