Thunderbird 3 eats up lots of disk space (750MB that I know of) - not enough disk space

RESOLVED INVALID

Status

Thunderbird
General
--
critical
RESOLVED INVALID
8 years ago
4 years ago

People

(Reporter: TBugz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [support], URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9) Gecko/20100315 Firefox/3.5.9 ( .NET CLR 3.5.30729)
Build Identifier: can't launch so don't know

Thunderbird crashed and would not come up again so I upgraded to 3.  I have very little disk space left (like 50MB).
It installed and started "indexing".  it took up all the disk space (50MB) and then my profile.ini disappeared (with 30 profiles each of which contained
10 email accounts) - took a long time to setup.

3 days later when I got my profile.ini created again, I purchased a usb flash drive and removed 750MB of porn off my computer to free up space for more
spam.

Thunderbird started indexing again and took up the full 750MB with indexing 3,000 messages.  Now I have no space for my porn (just kidding).

Where is it taking up so much disk space? so I can delete the files and rollback to Thunderbird 2 (or even 1 - because 1 has features that are broken
in 2 and logged 3 years ago but still not fixed).

If you will help me find out where Thunderbird created 750MB of poop files I will document it and help with the documentation project.
I have looked everywhere and somewhere Thunderbird had snarfed up 750MB of my hard drive space somehow.  it was the only program running
when all the disk space disappeared.

Please help.

Reproducible: Always

Steps to Reproduce:
1. download Thunderbird
2. install thunderbird
3. watch disk space eaten as it indexes thousands of messages and poops on your hard drive creating files somewhere.
(Reporter)

Comment 1

8 years ago
I am looking to find the files that thunderbird created or how it took up the disk space so I can have more disk space.   I have 0kb left on my disk drive and am afraid if I shut it down, it won't boot again.  I really super need to clean this up because I have a business trip this weekend and need my laptop on which it is installed.  thanks for your help.
Have you tried going to File > Compact Folders?

Updated

8 years ago
Summary: Thunderbird 3 eats up terrabytes of disk space (750MB that I know of) → Thunderbird 3 eats up lots of disk space (750MB that I know of)

Comment 3

7 years ago
At first, you should switch off the indexing: Tools - Options... - Advanced - Last checkbox.

By the way, if every Byte counts: Maybe you can gather a litte free space by using the Windows Drive Cleaner. Sorry, I don't know the actual English name, I use Vista de-DE and guessed it. Use Start > Run > cleanmgr.exe
Easiest way could be to temporarily uninstall some currently maybe unimportant freeware programs you can easily set up again (like f. e. Google Earth).

Comment 4

7 years ago
(In reply to comment #0)
> Thunderbird crashed and would not come up again so I upgraded to 3.  I have
> very little disk space left (like 50MB).
> It installed and started "indexing".  it took up all the disk space (50MB) and
> then my profile.ini disappeared (with 30 profiles each of which contained
> 10 email accounts) - took a long time to setup.
> 
> 3 days later when I got my profile.ini created again, I purchased a usb flash
> drive and removed 750MB of porn off my computer to free up space for more
> spam.
> 
> Thunderbird started indexing again and took up the full 750MB with indexing
> 3,000 messages.  Now I have no space for my porn (just kidding).

sounds like you need server sided spam/junk filtering.

> Where is it taking up so much disk space? so I can delete the files and
> rollback to Thunderbird 2 (or even 1 - because 1 has features that are broken
> in 2 and logged 3 years ago but still not fixed).
> 
> If you will help me find out where Thunderbird created 750MB of poop files I
> will document it and help with the documentation project.
> I have looked everywhere and somewhere Thunderbird had snarfed up 750MB of my
> hard drive space somehow.  it was the only program running
> when all the disk space disappeared.

thanks for volunteering. I have forwarded your contact info to the doc person!

http://support.mozillamessaging.com/en-US/kb/IMAP+Synchronization#Disk_space_usage is what you are seeking. However, it lacks instructions on how to delete your already downloaded mail and free up space. I just added that to the doc todo list a few days ago.  (there might also be an item at http://getsatisfaction.com/mozilla_messaging but I didn't look)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Summary: Thunderbird 3 eats up lots of disk space (750MB that I know of) → Thunderbird 3 eats up lots of disk space (750MB that I know of) - not enough disk space
Whiteboard: [support]
You need to log in before you can comment on or make changes to this bug.