After resuming from standby, first composed message is missing the signature from networked drive

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
--
minor
RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: Rainer Wiesenfarth, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.1.9) Gecko/20100317 Lightning/1.0b1 Thunderbird/3.0.4

After the computer resumes from standby, the first message composed is emtpy, a predefined signature is not present. Closing the composition window and opening a second one includes the signature.

MAY BE IMPORTANT: signature file resides on a mounted network share (using drive letters, not UNC)

Reproducible: Always

Steps to Reproduce:
1. Take computer into standby mode with running TB
2. Resume from standby
3. Create new message
Actual Results:  
The message is missing the signature given in the signature file on a mounted network share

Expected Results:  
The message should include the signature

Comment 1

8 years ago
Do you get any message in Tools > Error Console? Click on "Clear" before going to standby, then compose a new message after resuming and watch for any messages to appear.

Another test to see if it's a network-mount issue: If /before/ composing the new message you explicitly open the shared folder from Vista, does it work then? If yes, it would indicate that the share isn't "waking up" in time.
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> Do you get any message in Tools > Error Console? [...]
> 
> If /before/ composing the
> new message you explicitly open the shared folder from Vista, does it work
> then? [...]

I tried to check the above mentioned, but could not reproduce the issue with short standby periods. Usually I notice this in the morning, after some hours of standby. I will check again tomorrow morning...
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> (In reply to comment #1)
> > If /before/ composing the
> > new message you explicitly open the shared folder from Vista, does it work
> > then? [...]
> 
> [...] I will check again tomorrow morning...

The problem did not show this morning, when I accessed the network share before composing the message. I will try to reproduce it later without accessing the share.
(Reporter)

Comment 4

8 years ago
I tried it again today, this time without accessing the network share before composing the message.

(In reply to comment #1 - #3)
> Do you get any message in Tools > Error Console?

No, Error Console does not show a message.

> Another test to see if it's a network-mount issue: If /before/ composing the
> new message you explicitly open the shared folder from Vista, does it work
> then? If yes, it would indicate that the share isn't "waking up" in time.

Yes, it works if I access the network drive first. It does not work it TB is the first one to access the drive. However, the second attempt of TB works (as already mentioned), even without accessing the drive explicitely in between.

/Note/: This is not a race condition between system resume and TB message composition. TB reacts the way same minutes after resume. It is an issue of which process is the first to access the drive.

Seems like TB hits a timeout when accessing the signature file.

Updated

7 years ago
Severity: normal → minor
Summary: After resuming from standby, first composed message is missing the signature → After resuming from standby, first composed message is missing the signature from networked drive

Comment 5

5 years ago
Rainer, do you still see this problem?
Flags: needinfo?(rainer)
(Reporter)

Comment 6

5 years ago
Hmm, did not monitor this issue over the last years. I also did not notice the described problem recently, so probably it has been solved "en passant".

For me, it is perfectly ok to close this issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(rainer)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.