Canvas memory usage in about:memory is incorrect

RESOLVED FIXED in mozilla2.0b1

Status

()

RESOLVED FIXED
9 years ago
7 years ago

People

(Reporter: robarnold, Assigned: vlad)

Tracking

Trunk
mozilla2.0b1
x86
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 beta2+)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
about:memory is telling me I have all but 4 MB of my mapped memory devoted to canvas surfaces. This is most certainly incorrect.
Yeah, it's not correctly tracking canvases that are resized (it just keeps adding memory over and over).  Easy fix, will do asap.
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
Created attachment 454318 [details] [diff] [review]
fix

I /think/ this should fix it -- does this look right to you, rob?  Basically we don't report any memory usage if we were created with a presshell as opposed to coming from the DOM.
Attachment #454318 - Flags: review?
Attachment #454318 - Flags: review? → review?(tellrob)
(Reporter)

Comment 3

8 years ago
Comment on attachment 454318 [details] [diff] [review]
fix

Looks like this works.
Attachment #454318 - Flags: review?(tellrob) → review+
blocking2.0: ? → beta2+
http://hg.mozilla.org/mozilla-central/rev/1265868dc033
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3b1

Comment 5

7 years ago
Other Measurements
 -1.25 MB -- canvas-2d-pixel-bytes
  0.08 MB -- gfx-surface-image
  2.21 MB -- gfx-surface-xlib
 65.06 MB -- heap-allocated
  2.99 MB -- heap-dirty
 78.93 MB -- heap-unallocated
        2 -- js-compartments-system
        9 -- js-compartments-user
 26.00 MB -- js-gc-heap
  1.74 MB -- js-gc-heap-arena-unused
  0.00 MB -- js-gc-heap-chunk-clean-unused
 11.11 MB -- js-gc-heap-chunk-dirty-unused
   49.42% -- js-gc-heap-unused-fraction
      121 -- page-faults-hard
  782,042 -- page-faults-soft
155.82 MB -- resident
798.87 MB -- vsize

Found in linux x86_64 build of revision b384cfab8b1d. Is this a regression?
You need to log in before you can comment on or make changes to this bug.