Move tabs to the top when the window is maximized

RESOLVED DUPLICATE of bug 572160

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 572160
8 years ago
8 years ago

People

(Reporter: faaborg, Unassigned)

Tracking

({ux-efficiency})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

On windows Vista and Windows 7, the tab strip should be placed at the very top of the window (against the screen edge) when the window is maximized.  This gives us major a fitts's law win for tab switch operations.

Something that we will need to decide on 7 is if drag operations should do a restore down on the window as a whole, or do a tab tear off on the particular tab being dragged out.

On XP the menu bar should be against the screen edge, although that's a separate follow up bug.
(Reporter)

Updated

8 years ago
Keywords: ux-efficiency
(Reporter)

Comment 1

8 years ago
Created attachment 451655 [details]
Mockup of a maximized window
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 572160
You need to log in before you can comment on or make changes to this bug.