bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Java applet which has a login dialog and i can not put the focus on password field to enter password.

RESOLVED WORKSFORME

Status

()

Firefox
Keyboard Navigation
--
critical
RESOLVED WORKSFORME
8 years ago
4 years ago

People

(Reporter: kishorekumarskk, Unassigned)

Tracking

3.6 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Firefox/3.6.3

n the login dialog of the applet it does allow the user to enter the password in to the field. Password field does not takes the focus. I can not put the cursor in to the password field.
I tried tab key and it is not working. It looks to me that any key on key board is not working. I can see the focus on "Ok" button but when i press "enter" key it does not work. I am able to use the mouse. I can click "ok" and "cancel" buttons of the dialog using the mouse click. If there is no password then i can login to the applet. After that it works normally and all the fields in the applet take focus. But if there is a password set, then i am not able to login as i cannot enter anything to the password field in the login dialog. I have JRE 1.5 on my mac osx. It works fine with firefox 3.0 and has problem in 3.5 and above including 3.6.3.



Reproducible: Always

Actual Results:  
So it looks like keyboard does not work on the login dialog of the applet. Cursor can not be put in to password field.

Expected Results:  
Keyboard should work on the login dialog and cursor should be accepted in the password field.
(Reporter)

Updated

8 years ago
Severity: major → critical

Comment 1

6 years ago
kishorekumarskk, 
could you please update to a recent and supported version (see http://www.firefox.com/ ), create a new profile (see http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile and http://support.mozilla.org/kb/Managing%20profiles for more information), and test this again? 

If you still see this problem in the new profile, please add a comment to this report and tell us your exact version (by updating the "Version" field of this bug report) and your operating system (Windows, Mac OS, Linux, etc.) and provide a concrete testcase (attachment here, or a link to a page where this problem can be seen).

If the problem still happens but does not happen in the new profile, please enter the address "about:support" in the address bar and attach (using the "Add an attachment" link above) the output for your original profile (not the new profile), as the "Modified Preferences" section could be interesting. 

If the problem does not happen anymore at all, please set the status of this report to RESOLVED > WORKSFORME. Thanks for your help!
Version: unspecified → 3.6 Branch

Updated

6 years ago
Flags: needinfo?(kishorekumarskk)

Comment 2

5 years ago
Closing based on date of last comment and lack of response to request for info. If more info provided bug can be reopened.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
Flags: needinfo?(kishorekumarskk)
You need to log in before you can comment on or make changes to this bug.