Textareas and text inputs are not scrollable by panning

VERIFIED FIXED in Firefox 4.0

Status

Firefox for Android Graveyard
General
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: Martijn Wargers (zombie), Assigned: stechz)

Tracking

({testcase})

Trunk
Firefox 4.0
ARM
Android
testcase

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 451999 [details]
testcase

See testcase, it's not possible to scroll those textareas with the stylus.
You can only scroll them with the keyboard, when the textarea has the focus.

But in the disabled textarea case, the textarea can't have focus, so you are not able to scroll that textarea at all.
(Reporter)

Comment 1

7 years ago
On the Android device, that I have (Droid), this is quite annoying, since the hardware keyboard does not have arrow keys. This makes it impossible for me (afaik) to scroll textareas there.
tracking-fennec: --- → ?
OS: Windows 7 → Android
Hardware: x86 → ARM
Summary: Textareas and text inputs are not scrollable with the stylus → Textareas and text inputs are not scrollable by panning
tracking-fennec: ? → 2.0+
Assignee: nobody → wjohnston
tracking-fennec: 2.0+ → 2.0next+
tracking-fennec: 2.0next+ → 2.0+
Ben - if this is a dupe of bug 618975, mark it as such
Assignee: wjohnston → ben
(Assignee)

Comment 3

7 years ago
I'm not 100% sure, but it is certainly a dependency.
Depends on: 618975

Updated

7 years ago
tracking-fennec: 2.0+ → 2.0-
tracking-fennec: 2.0- → 2.0next+
(Reporter)

Comment 4

7 years ago
This seems to work now, so I guess this was fixed by bug 618975.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Verified fixed:
Mozilla/5.0 (Android; Linux armv71; rv2.0b13pre) Gecko/20110316 Firefox/4.0b13pre Fennec/4.0b6pre
Device: Droid 2 
OS: Android 2.2
Status: RESOLVED → VERIFIED
Target Milestone: --- → Firefox 4.0
You need to log in before you can comment on or make changes to this bug.